CVE-2024-31860 Apache Zeppelin: Path traversal vulnerability

Medium 6.5 Published Updated
Exploited in the wild
Not known
Fix
Available

What is CVE-2024-31860?

CVE-2024-31860 is a medium-severity vulnerability in Apache Zeppelin, published on 9 Apr 2024.

Official description

Improper Input Validation vulnerability in Apache Zeppelin.

By adding relative path indicators(E.g ..), attackers can see the contents for any files in the filesystem that the server account can access.  This issue affects Apache Zeppelin: from 0.9.0 before 0.11.0.

Users are recommended to upgrade to version 0.11.0, which fixes the issue.

Weakness: CWE-22

Which versions are affected by CVE-2024-31860?

2 open source packages ship an affected version, including org.apache.zeppelin:zeppelin-server. It affects 1 product.

PackageAffectedFixed in
org.apache.zeppelin:zeppelin-server MavenFrom 0.9.00.11.0
org.apache.zeppelin:zeppelin-server MavenFrom 0.9.00.11.0

Products include Apache Zeppelin.

How do I fix CVE-2024-31860?

Upgrade org.apache.zeppelin:zeppelin-server to 0.11.0 or later.

Is CVE-2024-31860 being exploited?

There is no known exploitation of CVE-2024-31860 in the wild and no public exploit code.

Sources

Also known as GHSA-g64r-xf39-q4p5.

Is CVE-2024-31860 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free