{"answers":{"affected":"2 open source packages ship an affected version, including org.apache.zeppelin:zeppelin-server. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-31860 in the wild and no public exploit code.","fix":"Upgrade org.apache.zeppelin:zeppelin-server to 0.11.0 or later.","what":"CVE-2024-31860 is a medium-severity vulnerability in Apache Zeppelin, published on 9 Apr 2024."},"fix_prompt":"Check this codebase for CVE-2024-31860 and fix it if it is affected.\n\nWhat it is: CVE-2024-31860 is a medium-severity vulnerability in Apache Zeppelin, published on 9 Apr 2024. \nExploitation: There is no known exploitation of CVE-2024-31860 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.zeppelin:zeppelin-server (Maven): affected from 0.9.0; fixed in 0.11.0\n- org.apache.zeppelin:zeppelin-server (Maven): affected from 0.9.0; fixed in 0.11.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-31860/ (Markdown: https://insights.sbomify.com/CVE-2024-31860/index.md)","id":"CVE-2024-31860","markdown":"https://insights.sbomify.com/CVE-2024-31860/index.md","name":"CVE-2024-31860","record":{"aliases":["GHSA-g64r-xf39-q4p5"],"analysis":null,"analysis_generated_by":null,"assigner":"apache","cpe":[{"product":"zeppelin","vendor":"apache"}],"cvss":{"score":6.5,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"Improper Input Validation vulnerability in Apache Zeppelin.\n\nBy adding relative path indicators(E.g ..), attackers can see the contents for any files in the filesystem that the server account can access. \nThis issue affects Apache Zeppelin: from 0.9.0 before 0.11.0.\n\nUsers are recommended to upgrade to version 0.11.0, which fixes the issue.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache Zeppelin: Path traversal vulnerability","id":"CVE-2024-31860","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":null,"year":"2024"},"n_packages":2,"n_references":2,"next":{"headline":"Code injection in Apache Zeppelin Shell","id":"CVE-2024-31861"},"packages":[{"ecosystem":"Maven","fixed":["0.11.0"],"introduced":["0.9.0"],"last_affected":[],"package":"org.apache.zeppelin:zeppelin-server","purl":null,"source":"GHSA-g64r-xf39-q4p5"},{"ecosystem":"Maven","fixed":["0.11.0"],"introduced":["0.9.0"],"last_affected":[],"package":"org.apache.zeppelin:zeppelin-server","purl":"pkg:maven/org.apache.zeppelin/zeppelin-server","source":"GHSA-g64r-xf39-q4p5"}],"prev":{"headline":"Member promoted to channel admin via playbooks run linking to channel","id":"CVE-2024-31859"},"products":["Apache Zeppelin"],"published":"2024-04-09","related":[{"cvss_score":9.8,"headline":"Apache Zeppelin: Remote code execution by adding malicious JDBC connection string","id":"CVE-2024-31864","kev_date_added":null,"published":"2024-04-09"},{"cvss_score":9.8,"headline":"Apache Zeppelin: Interpreter download command does not escape malicious code injection","id":"CVE-2024-31866","kev_date_added":null,"published":"2024-04-09"},{"cvss_score":9.8,"headline":"bash command injection in spark interpreter","id":"CVE-2019-10095","kev_date_added":null,"published":"2021-09-02"},{"cvss_score":8.8,"headline":"Improper Authentication in Apache Zeppelin","id":"CVE-2018-1317","kev_date_added":null,"published":"2019-04-23"},{"cvss_score":8.1,"headline":"Session Fixation in Apache Zeppelin","id":"CVE-2017-12619","kev_date_added":null,"published":"2019-04-23"},{"cvss_score":7.5,"headline":"Apache Zeppelin: Command Injection via CSWSH","id":"CVE-2024-51775","kev_date_added":null,"published":"2025-08-03"},{"cvss_score":7.5,"headline":"Apache Zeppelin: Arbitrary file read by adding malicious JDBC connection string","id":"CVE-2024-52279","kev_date_added":null,"published":"2025-08-03"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-05-06","vendors":["Apache Software Foundation"]},"summary":null,"url":"https://insights.sbomify.com/CVE-2024-31860/"}