CVE-2024-31862 Apache Zeppelin: Denial of service with invalid notebook name

Medium 5.3 Published Updated

An attacker can cause a denial of service in Apache Zeppelin by providing an invalid notebook name during note creation.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-31862?

CVE-2024-31862 is a medium-severity denial of service vulnerability in Apache Zeppelin, published on 9 Apr 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Improper Input Validation vulnerability in Apache Zeppelin when creating a new note from Zeppelin's UI.This issue affects Apache Zeppelin: from 0.10.1 before 0.11.0.

Users are recommended to upgrade to version 0.11.0, which fixes the issue.

Weakness: CWE-20

Which versions are affected by CVE-2024-31862?

2 open source packages ship an affected version, including org.apache.zeppelin:zeppelin-server. It affects 1 product.

PackageAffectedFixed in
org.apache.zeppelin:zeppelin-server MavenFrom 0.10.10.11.0
org.apache.zeppelin:zeppelin-server MavenFrom 0.10.10.11.0

Products include Apache Zeppelin.

How do I fix CVE-2024-31862?

Upgrade org.apache.zeppelin:zeppelin-server to 0.11.0 or later.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2024-31862 being exploited?

There is no known exploitation of CVE-2024-31862 in the wild and no public exploit code.

Sources

Also known as GHSA-6623-c6mr-6737.

Is CVE-2024-31862 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free