# CVE-2024-31862: Apache Zeppelin: Denial of service with invalid notebook name

> An attacker can cause a denial of service in Apache Zeppelin by providing an invalid notebook name during note creation.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Apr 2024
- **Updated:** 13 Feb 2025
- **Also known as:** GHSA-6623-c6mr-6737

## What is CVE-2024-31862?

CVE-2024-31862 is a medium-severity denial of service vulnerability in Apache Zeppelin, published on 9 Apr 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Improper Input Validation vulnerability in Apache Zeppelin when creating a new note from Zeppelin's UI.This issue affects Apache Zeppelin: from 0.10.1 before 0.11.0.

Users are recommended to upgrade to version 0.11.0, which fixes the issue.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2024-31862?

2 open source packages ship an affected version, including org.apache.zeppelin:zeppelin-server. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.zeppelin:zeppelin-server` | Maven | From 0.10.1 | 0.11.0 |
| `org.apache.zeppelin:zeppelin-server` | Maven | From 0.10.1 | 0.11.0 |

Products: Apache Zeppelin.

## How do I fix CVE-2024-31862?

Upgrade org.apache.zeppelin:zeppelin-server to 0.11.0 or later.

## Is CVE-2024-31862 being exploited?

There is no known exploitation of CVE-2024-31862 in the wild and no public exploit code.

## Other vulnerabilities in Apache Zeppelin

- [CVE-2024-31864](https://insights.sbomify.com/CVE-2024-31864/): Apache Zeppelin: Remote code execution by adding malicious JDBC connection string (critical 9.8)
- [CVE-2024-31866](https://insights.sbomify.com/CVE-2024-31866/): Apache Zeppelin: Interpreter download command does not escape malicious code injection (critical 9.8)
- [CVE-2019-10095](https://insights.sbomify.com/CVE-2019-10095/): bash command injection in spark interpreter (critical 9.8)
- [CVE-2018-1317](https://insights.sbomify.com/CVE-2018-1317/): Improper Authentication in Apache Zeppelin (high 8.8)
- [CVE-2017-12619](https://insights.sbomify.com/CVE-2017-12619/): Session Fixation in Apache Zeppelin (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-31862 and fix it if it is affected.

What it is: CVE-2024-31862 is a medium-severity denial of service vulnerability in Apache Zeppelin, published on 9 Apr 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-31862 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.zeppelin:zeppelin-server (Maven): affected from 0.10.1; fixed in 0.11.0
- org.apache.zeppelin:zeppelin-server (Maven): affected from 0.10.1; fixed in 0.11.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-31862/ (Markdown: https://insights.sbomify.com/CVE-2024-31862/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-31862
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-31862
- OSV: https://osv.dev/vulnerability/CVE-2024-31862

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-31862/
Summaries are generated and may contain mistakes; the official description above is the record.
