CVE-2024-31863 Apache Zeppelin: Replacing other users notebook, bypassing any permissions

Medium 5.3 Published Updated
Exploited in the wild
Not known
Fix
Available

What is CVE-2024-31863?

CVE-2024-31863 is a medium-severity vulnerability in Apache Zeppelin, published on 9 Apr 2024.

Official description

Authentication Bypass by Spoofing vulnerability by replacing to exsiting notes in Apache Zeppelin.This issue affects Apache Zeppelin: from 0.10.1 before 0.11.0.

Users are recommended to upgrade to version 0.11.0, which fixes the issue.

Weakness: CWE-290

Which versions are affected by CVE-2024-31863?

2 open source packages ship an affected version, including org.apache.zeppelin:zeppelin-server. It affects 1 product.

PackageAffectedFixed in
org.apache.zeppelin:zeppelin-server MavenFrom 0.10.10.11.0
org.apache.zeppelin:zeppelin-server MavenFrom 0.10.10.11.0

Products include Apache Zeppelin.

How do I fix CVE-2024-31863?

Upgrade org.apache.zeppelin:zeppelin-server to 0.11.0 or later.

Is CVE-2024-31863 being exploited?

There is no known exploitation of CVE-2024-31863 in the wild and no public exploit code.

Sources

Also known as GHSA-m65c-wmw9-vmpp.

Is CVE-2024-31863 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free