CVE-2024-31865 Apache Zeppelin: Cron arbitrary user impersonation with improper privileges

Medium 6.5 Published Updated

Attackers can impersonate users and execute notebooks with elevated privileges via improper input validation in the cron API.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-31865?

CVE-2024-31865 is a medium-severity vulnerability in Apache Zeppelin, published on 9 Apr 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Improper Input Validation vulnerability in Apache Zeppelin.

The attackers can call updating cron API with invalid or improper privileges so that the notebook can run with the privileges.

This issue affects Apache Zeppelin: from 0.8.2 before 0.11.1.

Users are recommended to upgrade to version 0.11.1, which fixes the issue.

Weakness: CWE-20

Which versions are affected by CVE-2024-31865?

2 open source packages ship an affected version, including org.apache.zeppelin:zeppelin-server. It affects 1 product.

PackageAffectedFixed in
org.apache.zeppelin:zeppelin-server MavenFrom 0.8.20.11.1
org.apache.zeppelin:zeppelin-server MavenFrom 0.8.20.11.1

Products include Apache Zeppelin.

How do I fix CVE-2024-31865?

Upgrade org.apache.zeppelin:zeppelin-server to 0.11.1 or later.

Is CVE-2024-31865 being exploited?

There is no known exploitation of CVE-2024-31865 in the wild and no public exploit code.

Sources

Also known as GHSA-g44m-x5h7-fr5q.

Is CVE-2024-31865 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free