# CVE-2024-31865: Apache Zeppelin: Cron arbitrary user impersonation with improper privileges

> Attackers can impersonate users and execute notebooks with elevated privileges via improper input validation in the cron API.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Apr 2024
- **Updated:** 13 Feb 2025
- **Also known as:** GHSA-g44m-x5h7-fr5q

## What is CVE-2024-31865?

CVE-2024-31865 is a medium-severity vulnerability in Apache Zeppelin, published on 9 Apr 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Improper Input Validation vulnerability in Apache Zeppelin.

The attackers can call updating cron API with invalid or improper privileges so that the notebook can run with the privileges.

This issue affects Apache Zeppelin: from 0.8.2 before 0.11.1.

Users are recommended to upgrade to version 0.11.1, which fixes the issue.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2024-31865?

2 open source packages ship an affected version, including org.apache.zeppelin:zeppelin-server. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.zeppelin:zeppelin-server` | Maven | From 0.8.2 | 0.11.1 |
| `org.apache.zeppelin:zeppelin-server` | Maven | From 0.8.2 | 0.11.1 |

Products: Apache Zeppelin.

## How do I fix CVE-2024-31865?

Upgrade org.apache.zeppelin:zeppelin-server to 0.11.1 or later.

## Is CVE-2024-31865 being exploited?

There is no known exploitation of CVE-2024-31865 in the wild and no public exploit code.

## Other vulnerabilities in Apache Zeppelin

- [CVE-2024-31864](https://insights.sbomify.com/CVE-2024-31864/): Apache Zeppelin: Remote code execution by adding malicious JDBC connection string (critical 9.8)
- [CVE-2024-31866](https://insights.sbomify.com/CVE-2024-31866/): Apache Zeppelin: Interpreter download command does not escape malicious code injection (critical 9.8)
- [CVE-2019-10095](https://insights.sbomify.com/CVE-2019-10095/): bash command injection in spark interpreter (critical 9.8)
- [CVE-2018-1317](https://insights.sbomify.com/CVE-2018-1317/): Improper Authentication in Apache Zeppelin (high 8.8)
- [CVE-2017-12619](https://insights.sbomify.com/CVE-2017-12619/): Session Fixation in Apache Zeppelin (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-31865 and fix it if it is affected.

What it is: CVE-2024-31865 is a medium-severity vulnerability in Apache Zeppelin, published on 9 Apr 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-31865 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.zeppelin:zeppelin-server (Maven): affected from 0.8.2; fixed in 0.11.1
- org.apache.zeppelin:zeppelin-server (Maven): affected from 0.8.2; fixed in 0.11.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-31865/ (Markdown: https://insights.sbomify.com/CVE-2024-31865/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-31865
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-31865
- OSV: https://osv.dev/vulnerability/CVE-2024-31865

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-31865/
Summaries are generated and may contain mistakes; the official description above is the record.
