CVE-2024-31866 Apache Zeppelin: Interpreter download command does not escape malicious code injection

Critical 9.8 Published Updated

Attackers can execute arbitrary code by overriding interpreter classpath configurations in Apache Zeppelin.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-31866?

CVE-2024-31866 is a critical code injection vulnerability in Apache Zeppelin, published on 9 Apr 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Improper Encoding or Escaping of Output vulnerability in Apache Zeppelin.

The attackers can execute shell scripts or malicious code by overriding configuration like ZEPPELIN_INTP_CLASSPATH_OVERRIDES. This issue affects Apache Zeppelin: from 0.8.2 before 0.11.1.

Users are recommended to upgrade to version 0.11.1, which fixes the issue.

Weakness: CWE-116

Which versions are affected by CVE-2024-31866?

2 open source packages ship an affected version, including org.apache.zeppelin:zeppelin-interpreter. It affects 1 product.

PackageAffectedFixed in
org.apache.zeppelin:zeppelin-interpreter MavenFrom 0.8.20.11.1
org.apache.zeppelin:zeppelin-interpreter MavenFrom 0.8.20.11.1

Products include Apache Zeppelin.

How do I fix CVE-2024-31866?

Upgrade org.apache.zeppelin:zeppelin-interpreter to 0.11.1 or later.

Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.

Is CVE-2024-31866 being exploited?

There is no known exploitation of CVE-2024-31866 in the wild and no public exploit code.

Sources

Also known as GHSA-86jx-wr74-xr74.

Is CVE-2024-31866 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free