{"answers":{"affected":"2 open source packages ship an affected version, including org.apache.zeppelin:zeppelin-interpreter. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-31866 in the wild and no public exploit code.","fix":"Upgrade org.apache.zeppelin:zeppelin-interpreter to 0.11.1 or later.","what":"CVE-2024-31866 is a critical code injection vulnerability in Apache Zeppelin, published on 9 Apr 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-31866 and fix it if it is affected.\n\nWhat it is: CVE-2024-31866 is a critical code injection vulnerability in Apache Zeppelin, published on 9 Apr 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-31866 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.zeppelin:zeppelin-interpreter (Maven): affected from 0.8.2; fixed in 0.11.1\n- org.apache.zeppelin:zeppelin-interpreter (Maven): affected from 0.8.2; fixed in 0.11.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-31866/ (Markdown: https://insights.sbomify.com/CVE-2024-31866/index.md)","id":"CVE-2024-31866","markdown":"https://insights.sbomify.com/CVE-2024-31866/index.md","name":"CVE-2024-31866","record":{"aliases":["GHSA-86jx-wr74-xr74"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":true,"product_category":"Apache Zeppelin","requires_auth":"none","summary":"Attackers can execute arbitrary code by overriding interpreter classpath configurations in Apache Zeppelin.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"zeppelin","vendor":"apache"}],"cvss":{"score":9.8,"severity":"critical","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-116","name":"Improper Encoding or Escaping of Output"}],"description":"Improper Encoding or Escaping of Output vulnerability in Apache Zeppelin.\n\nThe attackers can execute shell scripts or malicious code by overriding configuration like ZEPPELIN_INTP_CLASSPATH_OVERRIDES.\nThis issue affects Apache Zeppelin: from 0.8.2 before 0.11.1.\n\nUsers are recommended to upgrade to version 0.11.1, which fixes the issue.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache Zeppelin: Interpreter download command does not escape malicious code injection","id":"CVE-2024-31866","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"code_injection","year":"2024"},"n_packages":2,"n_references":3,"next":{"headline":"Apache Zeppelin: LDAP search filter query Injection Vulnerability","id":"CVE-2024-31867"},"packages":[{"ecosystem":"Maven","fixed":["0.11.1"],"introduced":["0.8.2"],"last_affected":[],"package":"org.apache.zeppelin:zeppelin-interpreter","purl":null,"source":"GHSA-86jx-wr74-xr74"},{"ecosystem":"Maven","fixed":["0.11.1"],"introduced":["0.8.2"],"last_affected":[],"package":"org.apache.zeppelin:zeppelin-interpreter","purl":"pkg:maven/org.apache.zeppelin/zeppelin-interpreter","source":"GHSA-86jx-wr74-xr74"}],"prev":{"headline":"Apache Zeppelin: Cron arbitrary user impersonation with improper privileges","id":"CVE-2024-31865"},"products":["Apache Zeppelin"],"published":"2024-04-09","related":[{"cvss_score":9.8,"headline":"Apache Zeppelin: Remote code execution by adding malicious JDBC connection string","id":"CVE-2024-31864","kev_date_added":null,"published":"2024-04-09"},{"cvss_score":9.8,"headline":"bash command injection in spark interpreter","id":"CVE-2019-10095","kev_date_added":null,"published":"2021-09-02"},{"cvss_score":8.8,"headline":"Improper Authentication in Apache Zeppelin","id":"CVE-2018-1317","kev_date_added":null,"published":"2019-04-23"},{"cvss_score":8.1,"headline":"Session Fixation in Apache Zeppelin","id":"CVE-2017-12619","kev_date_added":null,"published":"2019-04-23"},{"cvss_score":7.5,"headline":"Apache Zeppelin: Command Injection via CSWSH","id":"CVE-2024-51775","kev_date_added":null,"published":"2025-08-03"},{"cvss_score":7.5,"headline":"Apache Zeppelin: Arbitrary file read by adding malicious JDBC connection string","id":"CVE-2024-52279","kev_date_added":null,"published":"2025-08-03"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-02-13","vendors":["Apache Software Foundation"]},"summary":"Attackers can execute arbitrary code by overriding interpreter classpath configurations in Apache Zeppelin.","url":"https://insights.sbomify.com/CVE-2024-31866/"}