CVE-2024-31868 Apache Zeppelin: XSS vulnerability in the helium module

Medium 6.1 Published Updated

Attackers can inject malicious scripts via helium.json to execute code or hijack sessions in Apache Zeppelin.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2024-31868?

CVE-2024-31868 is a medium-severity cross-site scripting vulnerability in Apache Zeppelin, published on 9 Apr 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

Improper Encoding or Escaping of Output vulnerability in Apache Zeppelin.

The attackers can modify helium.json and exposure XSS attacks to normal users. This issue affects Apache Zeppelin: from 0.8.2 before 0.11.1.

Users are recommended to upgrade to version 0.11.1, which fixes the issue.

Weakness: CWE-79

Which versions are affected by CVE-2024-31868?

2 open source packages ship an affected version, including org.apache.zeppelin:zeppelin-interpreter. It affects 1 product.

PackageAffectedFixed in
org.apache.zeppelin:zeppelin-interpreter MavenFrom 0.8.20.11.1
org.apache.zeppelin:zeppelin-interpreter MavenFrom 0.8.20.11.1

Products include Apache Zeppelin.

How do I fix CVE-2024-31868?

Upgrade org.apache.zeppelin:zeppelin-interpreter to 0.11.1 or later.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2024-31868 being exploited?

There is no known exploitation of CVE-2024-31868 in the wild and no public exploit code.

Sources

Also known as GHSA-rrvf-5w4r-3x7v.

Is CVE-2024-31868 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free