{"answers":{"affected":"4 open source packages ship an affected version, including apache-airflow and airflow. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-31869 in the wild and no public exploit code.","fix":"Upgrade apache-airflow to 2.9.0 or later.","what":"CVE-2024-31869 is a medium-severity vulnerability in Apache Airflow, published on 18 Apr 2024. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-31869 and fix it if it is affected.\n\nWhat it is: CVE-2024-31869 is a medium-severity vulnerability in Apache Airflow, published on 18 Apr 2024. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-31869 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- apache-airflow (PyPI): affected from 2.7.0; fixed in 2.9.0\n- apache-airflow (PyPI): affected from 2.7.0; fixed in 2.9.0\n- apache-airflow (PyPI): affected from 2.7.0; fixed in 2.9.0\n- airflow (Bitnami): affected from 2.7.0; fixed in 2.9.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-31869/ (Markdown: https://insights.sbomify.com/CVE-2024-31869/index.md)","id":"CVE-2024-31869","markdown":"https://insights.sbomify.com/CVE-2024-31869/index.md","name":"CVE-2024-31869","record":{"aliases":["BIT-airflow-2024-31869","ECHO-21f9-88f5-a903","GHSA-2522-mrjc-m688","PYSEC-2026-1128"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":true,"product_category":"Apache Airflow","requires_auth":"low_privilege","summary":"Authenticated users can view sensitive provider configurations in the UI when non-sensitive-only mode is enabled, exposing secrets.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"airflow","vendor":"apache"}],"cvss":{"score":5.3,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-200","name":"Exposure of Sensitive Information to an Unauthorized Actor"}],"description":"Airflow versions 2.7.0 through 2.8.4 have a vulnerability that allows an authenticated user to see sensitive provider configuration via the \"configuration\" UI page when \"non-sensitive-only\" was set as \"webserver.expose_config\" configuration (The celery provider is the only community provider currently that has sensitive configurations). You should migrate to Airflow 2.9 or change your \"expose_config\" configuration to False as a workaround. This is similar, but different to  CVE-2023-46288 https://github.com/advisories/GHSA-9qqg-mh7c-chfq  which concerned API, not UI configuration page.","ecosystems":["Bitnami","PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache Airflow: Sensitive configuration for providers displayed when \"non-sensitive-only\" config used","id":"CVE-2024-31869","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"apache:airflow","products":["apache:airflow"],"type":"information_disclosure","year":"2024"},"n_packages":4,"n_references":3,"next":{"headline":"IBM i information disclosure","id":"CVE-2024-31870"},"packages":[{"ecosystem":"Bitnami","fixed":["2.9.0"],"introduced":["2.7.0"],"last_affected":[],"package":"airflow","purl":"pkg:bitnami/airflow","source":"BIT-airflow-2024-31869"},{"ecosystem":"PyPI","fixed":["2.9.0"],"introduced":["2.7.0"],"last_affected":[],"package":"apache-airflow","purl":null,"source":"GHSA-2522-mrjc-m688"},{"ecosystem":"PyPI","fixed":["2.9.0"],"introduced":["2.7.0"],"last_affected":[],"package":"apache-airflow","purl":"pkg:pypi/apache-airflow","source":"GHSA-2522-mrjc-m688"},{"ecosystem":"PyPI","fixed":["2.9.0"],"introduced":["2.7.0"],"last_affected":[],"package":"apache-airflow","purl":"pkg:pypi/apache-airflow","source":"PYSEC-2026-1128"}],"prev":{"headline":"Apache Zeppelin: XSS vulnerability in the helium module","id":"CVE-2024-31868"},"products":["Apache Airflow"],"published":"2024-04-18","related":[{"cvss_score":9.8,"headline":"Apache Airflow's Experimental API Authentication Bypass","id":"CVE-2020-13927","kev_date_added":"2022-01-18","published":"2020-11-10"},{"cvss_score":8.8,"headline":"Apache Airflow Command Injection","id":"CVE-2020-11978","kev_date_added":"2022-01-18","published":"2020-07-16"},{"cvss_score":9.8,"headline":"Apache Airflow: DAG author RCE on webserver via unrestricted import_string() in BaseSerialization.deserialize()","id":"CVE-2026-33264","kev_date_added":null,"published":"2026-07-07"},{"cvss_score":9.8,"headline":"Apache Airflow: Privilege escalation using airflow logs","id":"CVE-2023-25754","kev_date_added":null,"published":"2023-05-08"},{"cvss_score":9.8,"headline":"Apache Airflow, Apache Airflow MySQL Provider: Arbitrary file read via MySQL provider in Apache Airflow","id":"CVE-2023-22884","kev_date_added":null,"published":"2023-01-21"},{"cvss_score":9.8,"headline":"Apache Airflow Pinot provider allowed Command Injection","id":"CVE-2022-38649","kev_date_added":null,"published":"2022-11-22"},{"cvss_score":9.8,"headline":"Apache Airlfow Pig Provider RCE","id":"CVE-2022-40189","kev_date_added":null,"published":"2022-11-22"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-03-13","vendors":["Apache Software Foundation"]},"summary":"Authenticated users can view sensitive provider configurations in the UI when non-sensitive-only mode is enabled, exposing secrets.","url":"https://insights.sbomify.com/CVE-2024-31869/"}