# CVE-2024-31869: Apache Airflow: Sensitive configuration for providers displayed when "non-sensitive-only" config used

> Authenticated users can view sensitive provider configurations in the UI when non-sensitive-only mode is enabled, exposing secrets.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Apr 2024
- **Updated:** 13 Mar 2025
- **Also known as:** BIT-airflow-2024-31869, ECHO-21f9-88f5-a903, GHSA-2522-mrjc-m688, PYSEC-2026-1128

## What is CVE-2024-31869?

CVE-2024-31869 is a medium-severity vulnerability in Apache Airflow, published on 18 Apr 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Airflow versions 2.7.0 through 2.8.4 have a vulnerability that allows an authenticated user to see sensitive provider configuration via the "configuration" UI page when "non-sensitive-only" was set as "webserver.expose_config" configuration (The celery provider is the only community provider currently that has sensitive configurations). You should migrate to Airflow 2.9 or change your "expose_config" configuration to False as a workaround. This is similar, but different to  CVE-2023-46288 https://github.com/advisories/GHSA-9qqg-mh7c-chfq  which concerned API, not UI configuration page.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2024-31869?

4 open source packages ship an affected version, including apache-airflow and airflow. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache-airflow` | PyPI | From 2.7.0 | 2.9.0 |
| `apache-airflow` | PyPI | From 2.7.0 | 2.9.0 |
| `apache-airflow` | PyPI | From 2.7.0 | 2.9.0 |
| `airflow` | Bitnami | From 2.7.0 | 2.9.0 |

Products: Apache Airflow.

## How do I fix CVE-2024-31869?

Upgrade apache-airflow to 2.9.0 or later.

## Is CVE-2024-31869 being exploited?

There is no known exploitation of CVE-2024-31869 in the wild and no public exploit code.

## Other vulnerabilities in Apache Airflow

- [CVE-2020-13927](https://insights.sbomify.com/CVE-2020-13927/): Apache Airflow's Experimental API Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2020-11978](https://insights.sbomify.com/CVE-2020-11978/): Apache Airflow Command Injection (high 8.8, exploited in the wild)
- [CVE-2026-33264](https://insights.sbomify.com/CVE-2026-33264/): Apache Airflow: DAG author RCE on webserver via unrestricted import_string() in BaseSerialization.deserialize() (critical 9.8)
- [CVE-2023-25754](https://insights.sbomify.com/CVE-2023-25754/): Apache Airflow: Privilege escalation using airflow logs (critical 9.8)
- [CVE-2023-22884](https://insights.sbomify.com/CVE-2023-22884/): Apache Airflow, Apache Airflow MySQL Provider: Arbitrary file read via MySQL provider in Apache Airflow (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-31869 and fix it if it is affected.

What it is: CVE-2024-31869 is a medium-severity vulnerability in Apache Airflow, published on 18 Apr 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-31869 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache-airflow (PyPI): affected from 2.7.0; fixed in 2.9.0
- apache-airflow (PyPI): affected from 2.7.0; fixed in 2.9.0
- apache-airflow (PyPI): affected from 2.7.0; fixed in 2.9.0
- airflow (Bitnami): affected from 2.7.0; fixed in 2.9.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-31869/ (Markdown: https://insights.sbomify.com/CVE-2024-31869/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-31869
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-31869
- OSV: https://osv.dev/vulnerability/CVE-2024-31869

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-31869/
Summaries are generated and may contain mistakes; the official description above is the record.
