# CVE-2024-31979: Apache StreamPipes: Possibility of SSRF in pipeline element installation process

> Attackers can force StreamPipes to send HTTP requests to arbitrary addresses during pipeline element installation, potentially accessing internal resources.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Jul 2024
- **Updated:** 13 Sep 2024
- **Also known as:** GHSA-9gr7-gh74-qg9x, PYSEC-2024-174

## What is CVE-2024-31979?

CVE-2024-31979 is a high-severity server-side request forgery vulnerability in Apache StreamPipes, published on 17 Jul 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Server-Side Request Forgery (SSRF) vulnerability in Apache StreamPipes during installation process of pipeline elements.
Previously, StreamPipes allowed users to configure custom endpoints from which to install additional pipeline elements. 
These endpoints were not properly validated, allowing an attacker to get StreamPipes to send an HTTP GET request to an arbitrary address.
This issue affects Apache StreamPipes: through 0.93.0.

Users are recommended to upgrade to version 0.95.0, which fixes the issue.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2024-31979?

5 open source packages ship an affected version, including org.apache.streampipes:streampipes-parent and streampipes. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.streampipes:streampipes-parent` | Maven | All versions | 0.95.0 |
| `org.apache.streampipes:streampipes-parent` | Maven | All versions | 0.95.0 |
| `streampipes` | PyPI | All versions | 0.95.0 |
| `streampipes` | PyPI | All versions | 0.95.0 |
| `streampipes` | PyPI | All versions | 0.95.0 |

Products: Apache Streampipes.

## How do I fix CVE-2024-31979?

Upgrade org.apache.streampipes:streampipes-parent to 0.95.0 or later.

## Is CVE-2024-31979 being exploited?

There is no known exploitation of CVE-2024-31979 in the wild and no public exploit code.

## Other vulnerabilities in Apache StreamPipes

- [CVE-2024-29868](https://insights.sbomify.com/CVE-2024-29868/): Apache StreamPipes: Use of Cryptographically Weak Pseudo-Random Number Generator (PRNG) in Recovery Token Generation (critical 9.1)
- [CVE-2023-31469](https://insights.sbomify.com/CVE-2023-31469/): Apache StreamPipes: Privilege escalation through non-admin user (high 8.8)
- [CVE-2025-47411](https://insights.sbomify.com/CVE-2025-47411/): Apache StreamPipes: Leverage of User ID for Privilege Escalation (high 8.1)
- [CVE-2024-24778](https://insights.sbomify.com/CVE-2024-24778/): Apache StreamPipes: Resources Permission Escalation (medium 6.5)
- [CVE-2024-31411](https://insights.sbomify.com/CVE-2024-31411/): Apache StreamPipes: Potential remote code execution (RCE) via file upload (medium 6.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-31979 and fix it if it is affected.

What it is: CVE-2024-31979 is a high-severity server-side request forgery vulnerability in Apache StreamPipes, published on 17 Jul 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-31979 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.streampipes:streampipes-parent (Maven): affected all versions; fixed in 0.95.0
- org.apache.streampipes:streampipes-parent (Maven): affected all versions; fixed in 0.95.0
- streampipes (PyPI): affected all versions; fixed in 0.95.0
- streampipes (PyPI): affected all versions; fixed in 0.95.0
- streampipes (PyPI): affected all versions; fixed in 0.95.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-31979/ (Markdown: https://insights.sbomify.com/CVE-2024-31979/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-31979
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-31979
- OSV: https://osv.dev/vulnerability/CVE-2024-31979

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-31979/
Summaries are generated and may contain mistakes; the official description above is the record.
