CVE-2024-31981 XWiki Platform: Privilege escalation (PR) from user registration through PDFClass
Attackers can escalate privileges and execute remote code via PDF export templates in XWiki Platform, requiring an upgrade to patched versions.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-31981?
CVE-2024-31981 is a critical vulnerability in Xwiki Xwiki, published on 10 Apr 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
XWiki Platform is a generic wiki platform. Starting in version 3.0.1 and prior to versions 4.10.20, 15.5.4, and 15.10-rc-1, remote code execution is possible via PDF export templates. This vulnerability has been patched in XWiki 14.10.20, 15.5.4 and 15.10-rc-1. If PDF templates are not typically used on the instance, an administrator can create the document `XWiki.PDFClass` and block its edition, after making sure that it does not contain a `style` attribute. Otherwise, there are no known workarounds aside from upgrading.
Weakness: CWE-862
Which versions are affected by CVE-2024-31981?
6 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-oldcore. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.xwiki.platform:xwiki-platform-oldcore Maven | From 15.0-rc-1 | 15.5.4 |
org.xwiki.platform:xwiki-platform-oldcore Maven | From 15.0-rc-1 | 15.5.4 |
org.xwiki.platform:xwiki-platform-oldcore Maven | From 15.6-rc-1 | 15.10-rc-1 |
org.xwiki.platform:xwiki-platform-oldcore Maven | From 15.6-rc-1 | 15.10-rc-1 |
org.xwiki.platform:xwiki-platform-oldcore Maven | From 3.0.1 | 14.10.20 |
org.xwiki.platform:xwiki-platform-oldcore Maven | From 3.0.1 | 14.10.20 |
Products include Xwiki Xwiki.
How do I fix CVE-2024-31981?
Upgrade org.xwiki.platform:xwiki-platform-oldcore to a fixed version for your release line: 15.5.4, 15.10-rc-1 or 14.10.20.
Is CVE-2024-31981 being exploited?
There is no known exploitation of CVE-2024-31981 in the wild and no public exploit code.
Other vulnerabilities in Xwiki Xwiki
- CVE-2025-24893 XWiki Platform Eval Injection
- CVE-2025-53836 XWiki Rendering is vulnerable to RCE attacks when processing nested macros
- CVE-2024-55662 XWiki allows remote code execution through the extension sheet
- CVE-2024-55877 XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList
- CVE-2024-37901 XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet
Sources
Also known as GHSA-vxwr-wpjv-qjq7.