CVE-2024-31984 XWiki Platform: Remote code execution through space title and Solr space facet
Attackers can execute arbitrary Groovy code by crafting a space title, compromising the entire XWiki installation.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-31984?
CVE-2024-31984 is a critical code injection vulnerability in Xwiki Xwiki, published on 10 Apr 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
XWiki Platform is a generic wiki platform. Starting in version 7.2-rc-1 and prior to versions 4.10.20, 15.5.4, and 15.10-rc-1, by creating a document with a specially crafted title, it is possible to trigger remote code execution in the (Solr-based) search in XWiki. This allows any user who can edit the title of a space (all users by default) to execute any Groovy code in the XWiki installation which compromises the confidentiality, integrity and availability of the whole XWiki installation. This has been patched in XWiki 14.10.20, 15.5.4 and 15.10 RC1. As a workaround, manually apply the patch to the `Main.SolrSpaceFacet` page.
Which versions are affected by CVE-2024-31984?
6 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-search-solr-ui. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.xwiki.platform:xwiki-platform-search-solr-ui Maven | From 15.0-rc-1 | 15.5.4 |
org.xwiki.platform:xwiki-platform-search-solr-ui Maven | From 15.0-rc-1 | 15.5.4 |
org.xwiki.platform:xwiki-platform-search-solr-ui Maven | From 15.6-rc-1 | 15.10-rc-1 |
org.xwiki.platform:xwiki-platform-search-solr-ui Maven | From 15.6-rc-1 | 15.10-rc-1 |
org.xwiki.platform:xwiki-platform-search-solr-ui Maven | From 7.2-rc-1 | 14.10.20 |
org.xwiki.platform:xwiki-platform-search-solr-ui Maven | From 7.2-rc-1 | 14.10.20 |
Products include Xwiki Xwiki.
How do I fix CVE-2024-31984?
Upgrade org.xwiki.platform:xwiki-platform-search-solr-ui to a fixed version for your release line: 15.5.4, 15.10-rc-1 or 14.10.20.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2024-31984 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-31984 exists.
Other vulnerabilities in Xwiki Xwiki
- CVE-2025-24893 XWiki Platform Eval Injection
- CVE-2025-53836 XWiki Rendering is vulnerable to RCE attacks when processing nested macros
- CVE-2024-55662 XWiki allows remote code execution through the extension sheet
- CVE-2024-55877 XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList
- CVE-2024-37901 XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet
Sources
Also known as GHSA-xm4h-3jxr-m3c6.