CVE-2024-31987 XWiki Platform remote code execution from account via custom skins support
Authenticated users can achieve remote code execution by creating custom skins with template overrides, requiring an upgrade to XWiki.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-31987?
CVE-2024-31987 is a critical code injection vulnerability in Xwiki Xwiki, published on 10 Apr 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
XWiki Platform is a generic wiki platform. Starting in version 6.4-milestone-1 and prior to versions 4.10.19, 15.5.4, and 15.10-rc-1, any user who can edit any page like their profile can create a custom skin with a template override that is executed with programming right, thus allowing remote code execution. This has been patched in XWiki 14.10.19, 15.5.4 and 15.10RC1. No known workarounds are available except for upgrading.
Weakness: CWE-862
Which versions are affected by CVE-2024-31987?
6 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-oldcore. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.xwiki.platform:xwiki-platform-oldcore Maven | From 15.0-rc-1 | 15.5.4 |
org.xwiki.platform:xwiki-platform-oldcore Maven | From 15.0-rc-1 | 15.5.4 |
org.xwiki.platform:xwiki-platform-oldcore Maven | From 15.6-rc-1 | 15.10-rc-1 |
org.xwiki.platform:xwiki-platform-oldcore Maven | From 15.6-rc-1 | 15.10-rc-1 |
org.xwiki.platform:xwiki-platform-oldcore Maven | From 6.4-milestone-1 | 14.10.19 |
org.xwiki.platform:xwiki-platform-oldcore Maven | From 6.4-milestone-1 | 14.10.19 |
Products include Xwiki Xwiki.
How do I fix CVE-2024-31987?
Upgrade org.xwiki.platform:xwiki-platform-oldcore to a fixed version for your release line: 15.5.4, 15.10-rc-1 or 14.10.19.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2024-31987 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-31987 exists.
Other vulnerabilities in Xwiki Xwiki
- CVE-2025-24893 XWiki Platform Eval Injection
- CVE-2025-53836 XWiki Rendering is vulnerable to RCE attacks when processing nested macros
- CVE-2024-55662 XWiki allows remote code execution through the extension sheet
- CVE-2024-55877 XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList
- CVE-2024-37901 XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet
Sources
Also known as GHSA-cv55-v6rw-7r5v.