# CVE-2024-31987: XWiki Platform remote code execution from account via custom skins support

> Authenticated users can achieve remote code execution by creating custom skins with template overrides, requiring an upgrade to XWiki.

- **Severity:** Critical 10.0 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Apr 2024
- **Updated:** 20 Aug 2024
- **Also known as:** GHSA-cv55-v6rw-7r5v

## What is CVE-2024-31987?

CVE-2024-31987 is a critical code injection vulnerability in Xwiki Xwiki, published on 10 Apr 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

XWiki Platform is a generic wiki platform. Starting in version 6.4-milestone-1 and prior to versions 4.10.19, 15.5.4, and 15.10-rc-1, any user who can edit any page like their profile can create a custom skin with a template override that is executed with programming right, thus allowing remote code execution. This has been patched in XWiki 14.10.19, 15.5.4 and 15.10RC1. No known workarounds are available except for upgrading.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2024-31987?

6 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-oldcore. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.xwiki.platform:xwiki-platform-oldcore` | Maven | From 15.0-rc-1 | 15.5.4 |
| `org.xwiki.platform:xwiki-platform-oldcore` | Maven | From 15.0-rc-1 | 15.5.4 |
| `org.xwiki.platform:xwiki-platform-oldcore` | Maven | From 15.6-rc-1 | 15.10-rc-1 |
| `org.xwiki.platform:xwiki-platform-oldcore` | Maven | From 15.6-rc-1 | 15.10-rc-1 |
| `org.xwiki.platform:xwiki-platform-oldcore` | Maven | From 6.4-milestone-1 | 14.10.19 |
| `org.xwiki.platform:xwiki-platform-oldcore` | Maven | From 6.4-milestone-1 | 14.10.19 |

Products: Xwiki Xwiki.

## How do I fix CVE-2024-31987?

Upgrade org.xwiki.platform:xwiki-platform-oldcore to a fixed version for your release line: 15.5.4, 15.10-rc-1 or 14.10.19.

## Is CVE-2024-31987 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-31987 exists.

## Other vulnerabilities in Xwiki Xwiki

- [CVE-2025-24893](https://insights.sbomify.com/CVE-2025-24893/): XWiki Platform Eval Injection (critical 9.8, exploited in the wild)
- [CVE-2025-53836](https://insights.sbomify.com/CVE-2025-53836/): XWiki Rendering is vulnerable to RCE attacks when processing nested macros (critical 10.0)
- [CVE-2024-55662](https://insights.sbomify.com/CVE-2024-55662/): XWiki allows remote code execution through the extension sheet (critical 10.0)
- [CVE-2024-55877](https://insights.sbomify.com/CVE-2024-55877/): XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList (critical 10.0)
- [CVE-2024-37901](https://insights.sbomify.com/CVE-2024-37901/): XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-31987 and fix it if it is affected.

What it is: CVE-2024-31987 is a critical code injection vulnerability in Xwiki Xwiki, published on 10 Apr 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-31987 exists.

Affected packages and fixed versions:
- org.xwiki.platform:xwiki-platform-oldcore (Maven): affected from 15.0-rc-1; fixed in 15.5.4
- org.xwiki.platform:xwiki-platform-oldcore (Maven): affected from 15.0-rc-1; fixed in 15.5.4
- org.xwiki.platform:xwiki-platform-oldcore (Maven): affected from 15.6-rc-1; fixed in 15.10-rc-1
- org.xwiki.platform:xwiki-platform-oldcore (Maven): affected from 15.6-rc-1; fixed in 15.10-rc-1
- org.xwiki.platform:xwiki-platform-oldcore (Maven): affected from 6.4-milestone-1; fixed in 14.10.19
- org.xwiki.platform:xwiki-platform-oldcore (Maven): affected from 6.4-milestone-1; fixed in 14.10.19

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-31987/ (Markdown: https://insights.sbomify.com/CVE-2024-31987/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-31987
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-31987
- OSV: https://osv.dev/vulnerability/CVE-2024-31987

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-31987/
Summaries are generated and may contain mistakes; the official description above is the record.
