# CVE-2024-31988: XWiki Platform CSRF remote code execution through the realtime HTML Converter API

> Attackers can achieve remote code execution by tricking an admin into visiting a crafted URL, exploiting a CSRF flaw in the realtime HTML Converter API.

- **Severity:** Critical 9.7 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 10 Apr 2024
- **Updated:** 21 Feb 2025
- **Also known as:** GHSA-r5vh-gc3r-r24w

## What is CVE-2024-31988?

CVE-2024-31988 is a critical vulnerability in Xwiki Xwiki, published on 10 Apr 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

XWiki Platform is a generic wiki platform. Starting in version 13.9-rc-1 and prior to versions 4.10.19, 15.5.4, and 15.10-rc-1, when the realtime editor is installed in XWiki, it allows arbitrary remote code execution with the interaction of an admin user with programming right. More precisely, by getting an admin user to either visit a crafted URL or to view an image with this URL that could be in a comment, the attacker can get the admin to execute arbitrary XWiki syntax including scripting macros with Groovy or Python code. This compromises the confidentiality, integrity and availability of the whole XWiki installation. This vulnerability has been patched in XWiki 14.10.19, 15.5.4 and 15.9. As a workaround, one may update `RTFrontend.ConvertHTML` manually with the patch. This will, however, break some synchronization processes in the realtime editor, so upgrading should be the preferred way on installations where this editor is used.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2024-31988?

6 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-realtime-ui. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.xwiki.platform:xwiki-platform-realtime-ui` | Maven | From 13.9-rc-1 | 14.10.19 |
| `org.xwiki.platform:xwiki-platform-realtime-ui` | Maven | From 13.9-rc-1 | 14.10.19 |
| `org.xwiki.platform:xwiki-platform-realtime-ui` | Maven | From 15.0-rc-1 | 15.5.4 |
| `org.xwiki.platform:xwiki-platform-realtime-ui` | Maven | From 15.0-rc-1 | 15.5.4 |
| `org.xwiki.platform:xwiki-platform-realtime-ui` | Maven | From 15.6-rc-1 | 15.9 |
| `org.xwiki.platform:xwiki-platform-realtime-ui` | Maven | From 15.6-rc-1 | 15.9 |

Products: Xwiki Xwiki.

## How do I fix CVE-2024-31988?

Upgrade org.xwiki.platform:xwiki-platform-realtime-ui to a fixed version for your release line: 14.10.19, 15.5.4 or 15.9.

## Is CVE-2024-31988 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-31988 exists.

## Other vulnerabilities in Xwiki Xwiki

- [CVE-2025-24893](https://insights.sbomify.com/CVE-2025-24893/): XWiki Platform Eval Injection (critical 9.8, exploited in the wild)
- [CVE-2025-53836](https://insights.sbomify.com/CVE-2025-53836/): XWiki Rendering is vulnerable to RCE attacks when processing nested macros (critical 10.0)
- [CVE-2024-55662](https://insights.sbomify.com/CVE-2024-55662/): XWiki allows remote code execution through the extension sheet (critical 10.0)
- [CVE-2024-55877](https://insights.sbomify.com/CVE-2024-55877/): XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList (critical 10.0)
- [CVE-2024-37901](https://insights.sbomify.com/CVE-2024-37901/): XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-31988 and fix it if it is affected.

What it is: CVE-2024-31988 is a critical vulnerability in Xwiki Xwiki, published on 10 Apr 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-31988 exists.

Affected packages and fixed versions:
- org.xwiki.platform:xwiki-platform-realtime-ui (Maven): affected from 13.9-rc-1; fixed in 14.10.19
- org.xwiki.platform:xwiki-platform-realtime-ui (Maven): affected from 13.9-rc-1; fixed in 14.10.19
- org.xwiki.platform:xwiki-platform-realtime-ui (Maven): affected from 15.0-rc-1; fixed in 15.5.4
- org.xwiki.platform:xwiki-platform-realtime-ui (Maven): affected from 15.0-rc-1; fixed in 15.5.4
- org.xwiki.platform:xwiki-platform-realtime-ui (Maven): affected from 15.6-rc-1; fixed in 15.9
- org.xwiki.platform:xwiki-platform-realtime-ui (Maven): affected from 15.6-rc-1; fixed in 15.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-31988/ (Markdown: https://insights.sbomify.com/CVE-2024-31988/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-31988
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-31988
- OSV: https://osv.dev/vulnerability/CVE-2024-31988

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-31988/
Summaries are generated and may contain mistakes; the official description above is the record.
