# CVE-2024-31995: zcap has incomplete expiration checks in capability chains.

> Attackers can bypass expiration checks in delegated capability chains, allowing unauthorized access outside the intended time period.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Apr 2024
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-hp8h-7x69-4wmv

## What is CVE-2024-31995?

CVE-2024-31995 is a medium-severity vulnerability in digitalbazaar zcap, published on 10 Apr 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

`@digitalbazaar/zcap` provides JavaScript reference implementation for Authorization Capabilities. Prior to version 9.0.1, when invoking a capability with a chain depth of 2, i.e., it is delegated directly from the root capability, the `expires` property is not properly checked against the current date or other `date` param.  This can allow invocations outside of the original intended time period.  A zcap still cannot be invoked without being able to use the associated private key material. `@digitalbazaar/zcap` v9.0.1 fixes expiration checking. As a workaround, one may revoke a zcap at any time.

Weakness: CWE-613 (DEPRECATED: Insufficient Session Expiration)

## Which versions are affected by CVE-2024-31995?

2 open source packages ship an affected version, including @digitalbazaar/zcap.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@digitalbazaar/zcap` | npm | All versions | 9.0.1 |
| `@digitalbazaar/zcap` | npm | All versions | 9.0.1 |

## How do I fix CVE-2024-31995?

Upgrade @digitalbazaar/zcap to 9.0.1 or later.

## Is CVE-2024-31995 being exploited?

There is no known exploitation of CVE-2024-31995 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-31995 and fix it if it is affected.

What it is: CVE-2024-31995 is a medium-severity vulnerability in digitalbazaar zcap, published on 10 Apr 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-31995 in the wild and no public exploit code.

Affected packages and fixed versions:
- @digitalbazaar/zcap (npm): affected all versions; fixed in 9.0.1
- @digitalbazaar/zcap (npm): affected all versions; fixed in 9.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-31995/ (Markdown: https://insights.sbomify.com/CVE-2024-31995/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-31995
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-31995
- OSV: https://osv.dev/vulnerability/CVE-2024-31995

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-31995/
Summaries are generated and may contain mistakes; the official description above is the record.
