CVE-2024-31996 XWiki Commons missing escaping of `{` in Velocity escapetool allows remote code execution
Attackers can achieve remote code execution in XWiki by exploiting missing escaping of curly braces in the Velocity escapetool.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-31996?
CVE-2024-31996 is a critical code injection vulnerability in Xwiki Xwiki, published on 10 Apr 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
XWiki Platform is a generic wiki platform. Starting in version 3.0.1 and prior to versions 4.10.19, 15.5.4, and 15.10-rc-1, the HTML escaping of escaping tool that is used in XWiki doesn't escape `{`, which, when used in certain places, allows XWiki syntax injection and thereby remote code execution. The vulnerability has been fixed in XWiki 14.10.19, 15.5.5, and 15.9 RC1. Apart from upgrading, there is no generic workaround. However, replacing `$escapetool.html` by `$escapetool.xml` in XWiki documents fixes the vulnerability. In a standard XWiki installation, the maintainers are only aware of the document `Panels.PanelLayoutUpdate` that exposes this vulnerability, patching this document is thus a workaround. Any extension could expose this vulnerability and might thus require patching, too.
Which versions are affected by CVE-2024-31996?
6 open source packages ship an affected version, including org.xwiki.commons:xwiki-commons-velocity. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.xwiki.commons:xwiki-commons-velocity Maven | From 15.0-rc-1 | 15.5.4 |
org.xwiki.commons:xwiki-commons-velocity Maven | From 15.0-rc-1 | 15.5.4 |
org.xwiki.commons:xwiki-commons-velocity Maven | From 15.6-rc-1 | 15.9-rc-1 |
org.xwiki.commons:xwiki-commons-velocity Maven | From 15.6-rc-1 | 15.9-rc-1 |
org.xwiki.commons:xwiki-commons-velocity Maven | From 3.0.1 | 14.10.19 |
org.xwiki.commons:xwiki-commons-velocity Maven | From 3.0.1 | 14.10.19 |
Products include Xwiki Xwiki.
How do I fix CVE-2024-31996?
Upgrade org.xwiki.commons:xwiki-commons-velocity to a fixed version for your release line: 15.5.4, 15.9-rc-1 or 14.10.19.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2024-31996 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-31996 exists.
Other vulnerabilities in Xwiki Xwiki
- CVE-2025-24893 XWiki Platform Eval Injection
- CVE-2025-53836 XWiki Rendering is vulnerable to RCE attacks when processing nested macros
- CVE-2024-55662 XWiki allows remote code execution through the extension sheet
- CVE-2024-55877 XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList
- CVE-2024-37901 XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet
Sources
Also known as GHSA-hf43-47q4-fhq5.