# CVE-2024-31996: XWiki Commons missing escaping of `{` in Velocity escapetool allows remote code execution

> Attackers can achieve remote code execution in XWiki by exploiting missing escaping of curly braces in the Velocity escapetool.

- **Severity:** Critical 10.0 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Apr 2024
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-hf43-47q4-fhq5

## What is CVE-2024-31996?

CVE-2024-31996 is a critical code injection vulnerability in Xwiki Xwiki, published on 10 Apr 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

XWiki Platform is a generic wiki platform. Starting in version 3.0.1 and prior to versions 4.10.19, 15.5.4, and 15.10-rc-1, the HTML escaping of escaping tool that is used in XWiki doesn't escape `{`, which, when used in certain places, allows XWiki syntax injection and thereby remote code execution. The vulnerability has been fixed in XWiki 14.10.19, 15.5.5, and 15.9 RC1. Apart from upgrading, there is no generic workaround. However, replacing `$escapetool.html` by `$escapetool.xml` in XWiki documents fixes the vulnerability. In a standard XWiki installation, the maintainers are only aware of the document `Panels.PanelLayoutUpdate` that exposes this vulnerability, patching this document is thus a workaround. Any extension could expose this vulnerability and might thus require patching, too.

Weakness: CWE-94 (Improper Control of Generation of Code), CWE-95 (Improper Neutralization of Directives in Dynamically Evaluated Code)

## Which versions are affected by CVE-2024-31996?

6 open source packages ship an affected version, including org.xwiki.commons:xwiki-commons-velocity. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.xwiki.commons:xwiki-commons-velocity` | Maven | From 15.0-rc-1 | 15.5.4 |
| `org.xwiki.commons:xwiki-commons-velocity` | Maven | From 15.0-rc-1 | 15.5.4 |
| `org.xwiki.commons:xwiki-commons-velocity` | Maven | From 15.6-rc-1 | 15.9-rc-1 |
| `org.xwiki.commons:xwiki-commons-velocity` | Maven | From 15.6-rc-1 | 15.9-rc-1 |
| `org.xwiki.commons:xwiki-commons-velocity` | Maven | From 3.0.1 | 14.10.19 |
| `org.xwiki.commons:xwiki-commons-velocity` | Maven | From 3.0.1 | 14.10.19 |

Products: Xwiki Xwiki.

## How do I fix CVE-2024-31996?

Upgrade org.xwiki.commons:xwiki-commons-velocity to a fixed version for your release line: 15.5.4, 15.9-rc-1 or 14.10.19.

## Is CVE-2024-31996 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-31996 exists.

## Other vulnerabilities in Xwiki Xwiki

- [CVE-2025-24893](https://insights.sbomify.com/CVE-2025-24893/): XWiki Platform Eval Injection (critical 9.8, exploited in the wild)
- [CVE-2025-53836](https://insights.sbomify.com/CVE-2025-53836/): XWiki Rendering is vulnerable to RCE attacks when processing nested macros (critical 10.0)
- [CVE-2024-55662](https://insights.sbomify.com/CVE-2024-55662/): XWiki allows remote code execution through the extension sheet (critical 10.0)
- [CVE-2024-55877](https://insights.sbomify.com/CVE-2024-55877/): XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList (critical 10.0)
- [CVE-2024-37901](https://insights.sbomify.com/CVE-2024-37901/): XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-31996 and fix it if it is affected.

What it is: CVE-2024-31996 is a critical code injection vulnerability in Xwiki Xwiki, published on 10 Apr 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-31996 exists.

Affected packages and fixed versions:
- org.xwiki.commons:xwiki-commons-velocity (Maven): affected from 15.0-rc-1; fixed in 15.5.4
- org.xwiki.commons:xwiki-commons-velocity (Maven): affected from 15.0-rc-1; fixed in 15.5.4
- org.xwiki.commons:xwiki-commons-velocity (Maven): affected from 15.6-rc-1; fixed in 15.9-rc-1
- org.xwiki.commons:xwiki-commons-velocity (Maven): affected from 15.6-rc-1; fixed in 15.9-rc-1
- org.xwiki.commons:xwiki-commons-velocity (Maven): affected from 3.0.1; fixed in 14.10.19
- org.xwiki.commons:xwiki-commons-velocity (Maven): affected from 3.0.1; fixed in 14.10.19

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-31996/ (Markdown: https://insights.sbomify.com/CVE-2024-31996/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-31996
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-31996
- OSV: https://osv.dev/vulnerability/CVE-2024-31996

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-31996/
Summaries are generated and may contain mistakes; the official description above is the record.
