CVE-2024-31997 XWiki Platform remote code execution from account through UIExtension parameters
Attackers with edit rights can execute arbitrary code via UI extension parameters, compromising the entire XWiki installation.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-31997?
CVE-2024-31997 is a critical code injection vulnerability in Xwiki Xwiki, published on 10 Apr 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
XWiki Platform is a generic wiki platform. Prior to versions 4.10.19, 15.5.4, and 15.10-rc-1, parameters of UI extensions are always interpreted as Velocity code and executed with programming rights. Any user with edit right on any document like the user's own profile can create UI extensions. This allows remote code execution and thereby impacts the confidentiality, integrity and availability of the whole XWiki installation. This vulnerability has been patched in XWiki 14.10.19, 15.5.4 and 15.9-RC1. No known workarounds are available.
Weakness: CWE-862
Which versions are affected by CVE-2024-31997?
6 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-uiextension-api. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.xwiki.platform:xwiki-platform-uiextension-api Maven | All versions | 14.10.19 |
org.xwiki.platform:xwiki-platform-uiextension-api Maven | All versions | 14.10.19 |
org.xwiki.platform:xwiki-platform-uiextension-api Maven | From 15.0-rc-1 | 15.5.4 |
org.xwiki.platform:xwiki-platform-uiextension-api Maven | From 15.0-rc-1 | 15.5.4 |
org.xwiki.platform:xwiki-platform-uiextension-api Maven | From 15.6-rc-1 | 15.9-rc-1 |
org.xwiki.platform:xwiki-platform-uiextension-api Maven | From 15.6-rc-1 | 15.9-rc-1 |
Products include Xwiki Xwiki.
How do I fix CVE-2024-31997?
Upgrade org.xwiki.platform:xwiki-platform-uiextension-api to a fixed version for your release line: 14.10.19, 15.5.4 or 15.9-rc-1.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2024-31997 being exploited?
There is no known exploitation of CVE-2024-31997 in the wild and no public exploit code.
Other vulnerabilities in Xwiki Xwiki
- CVE-2025-24893 XWiki Platform Eval Injection
- CVE-2025-53836 XWiki Rendering is vulnerable to RCE attacks when processing nested macros
- CVE-2024-55662 XWiki allows remote code execution through the extension sheet
- CVE-2024-55877 XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList
- CVE-2024-37901 XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet
Sources
Also known as GHSA-c2gg-4gq4-jv5j.