# CVE-2024-31997: XWiki Platform remote code execution from account through UIExtension parameters

> Attackers with edit rights can execute arbitrary code via UI extension parameters, compromising the entire XWiki installation.

- **Severity:** Critical 10.0 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Apr 2024
- **Updated:** 13 Aug 2024
- **Also known as:** GHSA-c2gg-4gq4-jv5j

## What is CVE-2024-31997?

CVE-2024-31997 is a critical code injection vulnerability in Xwiki Xwiki, published on 10 Apr 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

XWiki Platform is a generic wiki platform. Prior to versions 4.10.19, 15.5.4, and 15.10-rc-1, parameters of UI extensions are always interpreted as Velocity code and executed with programming rights. Any user with edit right on any document like the user's own profile can create UI extensions. This allows remote code execution and thereby impacts the confidentiality, integrity and availability of the whole XWiki installation. This vulnerability has been patched in XWiki 14.10.19, 15.5.4 and 15.9-RC1. No known workarounds are available.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2024-31997?

6 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-uiextension-api. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.xwiki.platform:xwiki-platform-uiextension-api` | Maven | All versions | 14.10.19 |
| `org.xwiki.platform:xwiki-platform-uiextension-api` | Maven | All versions | 14.10.19 |
| `org.xwiki.platform:xwiki-platform-uiextension-api` | Maven | From 15.0-rc-1 | 15.5.4 |
| `org.xwiki.platform:xwiki-platform-uiextension-api` | Maven | From 15.0-rc-1 | 15.5.4 |
| `org.xwiki.platform:xwiki-platform-uiextension-api` | Maven | From 15.6-rc-1 | 15.9-rc-1 |
| `org.xwiki.platform:xwiki-platform-uiextension-api` | Maven | From 15.6-rc-1 | 15.9-rc-1 |

Products: Xwiki Xwiki.

## How do I fix CVE-2024-31997?

Upgrade org.xwiki.platform:xwiki-platform-uiextension-api to a fixed version for your release line: 14.10.19, 15.5.4 or 15.9-rc-1.

## Is CVE-2024-31997 being exploited?

There is no known exploitation of CVE-2024-31997 in the wild and no public exploit code.

## Other vulnerabilities in Xwiki Xwiki

- [CVE-2025-24893](https://insights.sbomify.com/CVE-2025-24893/): XWiki Platform Eval Injection (critical 9.8, exploited in the wild)
- [CVE-2025-53836](https://insights.sbomify.com/CVE-2025-53836/): XWiki Rendering is vulnerable to RCE attacks when processing nested macros (critical 10.0)
- [CVE-2024-55662](https://insights.sbomify.com/CVE-2024-55662/): XWiki allows remote code execution through the extension sheet (critical 10.0)
- [CVE-2024-55877](https://insights.sbomify.com/CVE-2024-55877/): XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList (critical 10.0)
- [CVE-2024-37901](https://insights.sbomify.com/CVE-2024-37901/): XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-31997 and fix it if it is affected.

What it is: CVE-2024-31997 is a critical code injection vulnerability in Xwiki Xwiki, published on 10 Apr 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-31997 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.xwiki.platform:xwiki-platform-uiextension-api (Maven): affected all versions; fixed in 14.10.19
- org.xwiki.platform:xwiki-platform-uiextension-api (Maven): affected all versions; fixed in 14.10.19
- org.xwiki.platform:xwiki-platform-uiextension-api (Maven): affected from 15.0-rc-1; fixed in 15.5.4
- org.xwiki.platform:xwiki-platform-uiextension-api (Maven): affected from 15.0-rc-1; fixed in 15.5.4
- org.xwiki.platform:xwiki-platform-uiextension-api (Maven): affected from 15.6-rc-1; fixed in 15.9-rc-1
- org.xwiki.platform:xwiki-platform-uiextension-api (Maven): affected from 15.6-rc-1; fixed in 15.9-rc-1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-31997/ (Markdown: https://insights.sbomify.com/CVE-2024-31997/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-31997
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-31997
- OSV: https://osv.dev/vulnerability/CVE-2024-31997

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-31997/
Summaries are generated and may contain mistakes; the official description above is the record.
