# CVE-2024-32001: SpiceDB: LookupSubjects may return partial results if a specific kind of relation is used

> SpiceDB may return incomplete results for specific relation schemas, potentially allowing unauthorized access if negative authorization decisions are made.

- **Severity:** Low 2.2 (`CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Apr 2024
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-j85q-46hg-36p2, GO-2024-2716

## What is CVE-2024-32001?

CVE-2024-32001 is a low-severity vulnerability in authzed spicedb, published on 10 Apr 2024. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

SpiceDB is a graph database purpose-built for storing and evaluating access control data. Use of a relation of the form: `relation folder: folder | folder#parent` with an arrow such as `folder->view` can cause LookupSubjects to only return the subjects found under subjects for either `folder` or `folder#parent`. This bug only manifests if the same subject type is used multiple types in a relation, relationships exist for both subject types and an arrow is used over the relation. Any user making a negative authorization decision based on the results of a LookupSubjects request with version before v1.30.1 is affected. Version 1.30.1 contains a patch for the issue. As a workaround, avoid using LookupSubjects for negative authorization decisions and/or avoid using the broken schema.

Weakness: CWE-755 (Improper Handling of Exceptional Conditions)

## Which versions are affected by CVE-2024-32001?

3 open source packages ship an affected version, including github.com/authzed/spicedb. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/authzed/spicedb` | Go | All versions | 1.30.1 |
| `github.com/authzed/spicedb` | Go | All versions | 1.30.1 |
| `github.com/authzed/spicedb` | Go | All versions | 1.30.1 |

Products: Authzed Spicedb.

## How do I fix CVE-2024-32001?

Upgrade github.com/authzed/spicedb to 1.30.1 or later.

## Is CVE-2024-32001 being exploited?

There is no known exploitation of CVE-2024-32001 in the wild and no public exploit code.

## Other vulnerabilities in authzed spicedb

- [CVE-2023-29193](https://insights.sbomify.com/CVE-2023-29193/): SpiceDB binding metrics port to untrusted networks and can leak command-line flags (high 8.7)
- [CVE-2022-21646](https://insights.sbomify.com/CVE-2022-21646/): Lookup operations do not take into account wildcards in SpiceDB (high 8.1)
- [CVE-2024-27101](https://insights.sbomify.com/CVE-2024-27101/): Integer overflow in chunking helper causes dispatching to miss elements or panic (high 7.3)
- [CVE-2026-40091](https://insights.sbomify.com/CVE-2026-40091/): SpiceDB: SPICEDB_DATASTORE_CONN_URI is leaked on startup logs (medium 6.0)
- [CVE-2023-46255](https://insights.sbomify.com/CVE-2023-46255/): `SPICEDB_DATASTORE_CONN_URI` is leaked when URI cannot be parsed (medium 4.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-32001 and fix it if it is affected.

What it is: CVE-2024-32001 is a low-severity vulnerability in authzed spicedb, published on 10 Apr 2024. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-32001 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/authzed/spicedb (Go): affected all versions; fixed in 1.30.1
- github.com/authzed/spicedb (Go): affected all versions; fixed in 1.30.1
- github.com/authzed/spicedb (Go): affected all versions; fixed in 1.30.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-32001/ (Markdown: https://insights.sbomify.com/CVE-2024-32001/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-32001
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-32001
- OSV: https://osv.dev/vulnerability/CVE-2024-32001

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-32001/
Summaries are generated and may contain mistakes; the official description above is the record.
