{"answers":{"affected":"2 open source packages ship an affected version, including winter/wn-dusk-plugin.","exploited":"There is no known exploitation of CVE-2024-32003 in the wild and no public exploit code.","fix":"Upgrade winter/wn-dusk-plugin to 2.1.0 or later.","what":"CVE-2024-32003 is a high-severity authentication bypass vulnerability in wintercms wn-dusk-plugin, published on 12 Apr 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2024-32003 and fix it if it is affected.\n\nWhat it is: CVE-2024-32003 is a high-severity authentication bypass vulnerability in wintercms wn-dusk-plugin, published on 12 Apr 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2024-32003 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- winter/wn-dusk-plugin (Packagist): affected all versions; fixed in 2.1.0\n- winter/wn-dusk-plugin (Packagist): affected all versions; fixed in 2.1.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-32003/ (Markdown: https://insights.sbomify.com/CVE-2024-32003/index.md)","id":"CVE-2024-32003","markdown":"https://insights.sbomify.com/CVE-2024-32003/index.md","name":"CVE-2024-32003","record":{"aliases":["GHSA-chcp-g9j5-3xxx"],"analysis":{"component_type":"cms_plugin","fix_type":"patch","impacts":["account_takeover"],"network_reachable":"yes","non_default_config":true,"product_category":"Winter CMS plugin","requires_auth":"none","summary":"Misconfigured Winter CMS installations with the Dusk plugin allow attackers to bypass authentication and access any user account.","user_interaction":"required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":8.8,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-269","name":"Improper Privilege Management"}],"description":"wn-dusk-plugin (Dusk plugin) is a plugin which integrates Laravel Dusk browser testing into Winter CMS. The Dusk plugin provides some special routes as part of its testing framework to allow a browser environment (such as headless Chrome) to act as a user in the Backend or User plugin without having to go through authentication. This route is `[[URL]]/_dusk/login/[[USER ID]]/[[MANAGER]]` - where `[[URL]]` is the base URL of the site, `[[USER ID]]` is the ID of the user account and `[[MANAGER]]` is the authentication manager (either `backend` for Backend, or `user` for the User plugin). If a configuration of a site using the Dusk plugin is set up in such a way that the Dusk plugin is available publicly and the test cases in Dusk are run with live data, this route may potentially be used to gain access to any user account in either the Backend or User plugin without authentication. As indicated in the `README`, this plugin should only be used in development and should *NOT* be used in a production instance. It is specifically recommended that the plugin be installed as a development dependency only in Composer. In order to remediate this issue, the special routes used above will now no longer be registered unless the `APP_ENV` environment variable is specifically set to `dusk`. Since Winter by default does not use this environment variable and it is not populated by default, it will only exist if Dusk's automatic configuration is used (which won't exhibit this vulnerability) or if a developer manually specifies it in their configuration. The automatic configuration performed by the Dusk plugin has also been hardened by default to use sane defaults and not allow external environment variables to leak into this configuration. This will only affect users in which the Winter CMS installation meets ALL the following criteria: 1. The Dusk plugin is installed in the Winter CMS instance. 2. The application is in production mode (ie. the `debug` config value is set to `true` in `config/app.php`). 3. The Dusk plugin's automatic configuration has been overridden, either by providing a custom `.env.dusk` file or by providing custom configuration in the `config/dusk` folder, or by providing configuration environment variables externally. 4. The environment has been configured to use production data in the database for testing, and not the temporary SQLite database that Dusk uses by default. 5. The application is connectable via the web. This issue has been fixed in version 2.1.0. Users are advised to upgrade.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Dusk plugin may allow unfettered user authentication in misconfigured installs","id":"CVE-2024-32003","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"auth_bypass","year":"2024"},"n_packages":2,"n_references":2,"next":{"headline":"Git vulnerable to Remote Code Execution while cloning special-crafted local repositories","id":"CVE-2024-32004"},"packages":[{"ecosystem":"Packagist","fixed":["2.1.0"],"introduced":["0"],"last_affected":[],"package":"winter/wn-dusk-plugin","purl":null,"source":"GHSA-chcp-g9j5-3xxx"},{"ecosystem":"Packagist","fixed":["2.1.0"],"introduced":["0"],"last_affected":[],"package":"winter/wn-dusk-plugin","purl":"pkg:composer/winter/wn-dusk-plugin","source":"GHSA-chcp-g9j5-3xxx"}],"prev":{"headline":"Git's recursive clones on case-insensitive filesystems that support symlinks are susceptible to Remote Code Execution","id":"CVE-2024-32002"},"products":["wn-dusk-plugin"],"published":"2024-04-12","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2024-08-02","vendors":["wintercms"]},"summary":"Misconfigured Winter CMS installations with the Dusk plugin allow attackers to bypass authentication and access any user account.","url":"https://insights.sbomify.com/CVE-2024-32003/"}