CVE-2024-32004 Git vulnerable to Remote Code Execution while cloning special-crafted local repositories
Attackers can execute arbitrary code on a victim's machine by tricking them into cloning a specially crafted local Git repository.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Local or same network only
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-32004?
CVE-2024-32004 is a high-severity code injection vulnerability in Debian Debian Linux, published on 14 May 2024. It can only be exploited from the same machine or local network, with no action from the victim.
Official description
Git is a revision control system. Prior to versions 2.45.1, 2.44.1, 2.43.4, 2.42.2, 2.41.1, 2.40.2, and 2.39.4, an attacker can prepare a local repository in such a way that, when cloned, will execute arbitrary code during the operation. The problem has been patched in versions 2.45.1, 2.44.1, 2.43.4, 2.42.2, 2.41.1, 2.40.2, and 2.39.4. As a workaround, avoid cloning repositories from untrusted sources.
Weakness: CWE-114
Which versions are affected by CVE-2024-32004?
1 open source package ship an affected version, including git. It affects 3 products.
| Package | Affected | Fixed in |
|---|---|---|
git Bitnami | All versions | 2.39.4, 2.40.2, 2.41.1, 2.42.2, 2.43.4, 2.44.1, 2.45.1 |
Linux distribution packages (19)
git Red Hat:rhel_aus:8.2::appstream | All versions | 0:2.18.4-5.el8_2 |
git-all Red Hat:rhel_aus:8.2::appstream | All versions | 0:2.18.4-5.el8_2 |
git-core Red Hat:rhel_aus:8.2::appstream | All versions | 0:2.18.4-5.el8_2 |
git-core-debuginfo Red Hat:rhel_aus:8.2::appstream | All versions | 0:2.18.4-5.el8_2 |
git-core-doc Red Hat:rhel_aus:8.2::appstream | All versions | 0:2.18.4-5.el8_2 |
git-daemon Red Hat:rhel_aus:8.2::appstream | All versions | 0:2.18.4-5.el8_2 |
git-daemon-debuginfo Red Hat:rhel_aus:8.2::appstream | All versions | 0:2.18.4-5.el8_2 |
git-debuginfo Red Hat:rhel_aus:8.2::appstream | All versions | 0:2.18.4-5.el8_2 |
git-debugsource Red Hat:rhel_aus:8.2::appstream | All versions | 0:2.18.4-5.el8_2 |
git-email Red Hat:rhel_aus:8.2::appstream | All versions | 0:2.18.4-5.el8_2 |
git-gui Red Hat:rhel_aus:8.2::appstream | All versions | 0:2.18.4-5.el8_2 |
git-instaweb Red Hat:rhel_aus:8.2::appstream | All versions | 0:2.18.4-5.el8_2 |
git-subtree Red Hat:rhel_aus:8.2::appstream | All versions | 0:2.18.4-5.el8_2 |
git-svn Red Hat:rhel_aus:8.2::appstream | All versions | 0:2.18.4-5.el8_2 |
git-svn-debuginfo Red Hat:rhel_aus:8.2::appstream | All versions | 0:2.18.4-5.el8_2 |
gitk Red Hat:rhel_aus:8.2::appstream | All versions | 0:2.18.4-5.el8_2 |
gitweb Red Hat:rhel_aus:8.2::appstream | All versions | 0:2.18.4-5.el8_2 |
perl-Git Red Hat:rhel_aus:8.2::appstream | All versions | 0:2.18.4-5.el8_2 |
perl-Git-SVN Red Hat:rhel_aus:8.2::appstream | All versions | 0:2.18.4-5.el8_2 |
Products include Debian Debian Linux, Fedoraproject Fedora, Git-Scm Git.
How do I fix CVE-2024-32004?
Upgrade git to a fixed version for your release line: 2.39.4, 2.40.2, 2.41.1 or 2.42.2.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2024-32004 being exploited?
There is no known exploitation of CVE-2024-32004 in the wild and no public exploit code.
Public exploit code: 2 proofs of concept on GitHub.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as ALPINE-CVE-2024-32004, AZL-42022, AZL-43041, BELL-CVE-2024-32004, BIT-git-2024-32004, CLEANSTART-2026-KN73658 and 12 more.