# CVE-2024-32004: Git vulnerable to Remote Code Execution while cloning special-crafted local repositories

> Attackers can execute arbitrary code on a victim's machine by tricking them into cloning a specially crafted local Git repository.

- **Severity:** High 8.2 (`CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 May 2024
- **Updated:** 4 Nov 2025
- **Also known as:** ALPINE-CVE-2024-32004, AZL-42022, AZL-43041, BELL-CVE-2024-32004, BIT-git-2024-32004, CLEANSTART-2026-KN73658, CLSA-2024-1719943366, CLSA-2024-1722529344, CLSA-2024-1725652305, CLSA-2024-1725652323, CLSA-2024-1725655852, CLSA-2025-1737155612, CLSA-2025-1748464675, CLSA-2026-1768395600, DEBIAN-CVE-2024-32004, GHSA-xfc6-vwr8-r389, RHSA-2024:7701, UBUNTU-CVE-2024-32004

## What is CVE-2024-32004?

CVE-2024-32004 is a high-severity code injection vulnerability in Debian Debian Linux, published on 14 May 2024. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Git is a revision control system. Prior to versions 2.45.1, 2.44.1, 2.43.4, 2.42.2, 2.41.1, 2.40.2, and 2.39.4, an attacker can prepare a local repository in such a way that, when cloned, will execute arbitrary code during the operation. The problem has been patched in versions 2.45.1, 2.44.1, 2.43.4, 2.42.2, 2.41.1, 2.40.2, and 2.39.4. As a workaround, avoid cloning repositories from untrusted sources.

Weakness: CWE-114 (Process Control)

## Which versions are affected by CVE-2024-32004?

1 open source package ship an affected version, including git. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `git` | Bitnami | All versions | 2.39.4, 2.40.2, 2.41.1, 2.42.2, 2.43.4, 2.44.1, 2.45.1 |
| `git` | Red Hat:rhel_aus:8.2::appstream | All versions | 0:2.18.4-5.el8_2 |
| `git-all` | Red Hat:rhel_aus:8.2::appstream | All versions | 0:2.18.4-5.el8_2 |
| `git-core` | Red Hat:rhel_aus:8.2::appstream | All versions | 0:2.18.4-5.el8_2 |
| `git-core-debuginfo` | Red Hat:rhel_aus:8.2::appstream | All versions | 0:2.18.4-5.el8_2 |
| `git-core-doc` | Red Hat:rhel_aus:8.2::appstream | All versions | 0:2.18.4-5.el8_2 |
| `git-daemon` | Red Hat:rhel_aus:8.2::appstream | All versions | 0:2.18.4-5.el8_2 |
| `git-daemon-debuginfo` | Red Hat:rhel_aus:8.2::appstream | All versions | 0:2.18.4-5.el8_2 |
| `git-debuginfo` | Red Hat:rhel_aus:8.2::appstream | All versions | 0:2.18.4-5.el8_2 |
| `git-debugsource` | Red Hat:rhel_aus:8.2::appstream | All versions | 0:2.18.4-5.el8_2 |
| `git-email` | Red Hat:rhel_aus:8.2::appstream | All versions | 0:2.18.4-5.el8_2 |
| `git-gui` | Red Hat:rhel_aus:8.2::appstream | All versions | 0:2.18.4-5.el8_2 |
| `git-instaweb` | Red Hat:rhel_aus:8.2::appstream | All versions | 0:2.18.4-5.el8_2 |
| `git-subtree` | Red Hat:rhel_aus:8.2::appstream | All versions | 0:2.18.4-5.el8_2 |
| `git-svn` | Red Hat:rhel_aus:8.2::appstream | All versions | 0:2.18.4-5.el8_2 |
| `git-svn-debuginfo` | Red Hat:rhel_aus:8.2::appstream | All versions | 0:2.18.4-5.el8_2 |
| `gitk` | Red Hat:rhel_aus:8.2::appstream | All versions | 0:2.18.4-5.el8_2 |
| `gitweb` | Red Hat:rhel_aus:8.2::appstream | All versions | 0:2.18.4-5.el8_2 |
| `perl-Git` | Red Hat:rhel_aus:8.2::appstream | All versions | 0:2.18.4-5.el8_2 |
| `perl-Git-SVN` | Red Hat:rhel_aus:8.2::appstream | All versions | 0:2.18.4-5.el8_2 |

Products: Debian Debian Linux, Fedoraproject Fedora, Git-Scm Git.

## How do I fix CVE-2024-32004?

Upgrade git to a fixed version for your release line: 2.39.4, 2.40.2, 2.41.1 or 2.42.2.

## Is CVE-2024-32004 being exploited?

There is no known exploitation of CVE-2024-32004 in the wild and no public exploit code.

Public exploit code:

- https://github.com/Wadewfsssss/CVE-2024-32004 (github_poc): https://github.com/Wadewfsssss/CVE-2024-32004
- https://github.com/10cks/CVE-2024-32004-POC (github_poc): https://github.com/10cks/CVE-2024-32004-POC

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-32004 and fix it if it is affected.

What it is: CVE-2024-32004 is a high-severity code injection vulnerability in Debian Debian Linux, published on 14 May 2024. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-32004 in the wild and no public exploit code.

Affected packages and fixed versions:
- git (Bitnami): affected all versions; fixed in 2.39.4, 2.40.2, 2.41.1, 2.42.2, 2.43.4, 2.44.1, 2.45.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-32004/ (Markdown: https://insights.sbomify.com/CVE-2024-32004/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-32004
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-32004
- OSV: https://osv.dev/vulnerability/CVE-2024-32004

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-32004/
Summaries are generated and may contain mistakes; the official description above is the record.
