{"answers":{"affected":"3 open source packages ship an affected version, including nicegui.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-32005 exists.","fix":"Upgrade nicegui to 1.4.21 or later.","what":"CVE-2024-32005 is a high-severity path traversal vulnerability in zauberzeug nicegui, published on 12 Apr 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-32005 and fix it if it is affected.\n\nWhat it is: CVE-2024-32005 is a high-severity path traversal vulnerability in zauberzeug nicegui, published on 12 Apr 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-32005 exists.\n\nAffected packages and fixed versions:\n- nicegui (PyPI): affected from 1.4.6; fixed in 1.4.21\n- nicegui (PyPI): affected from 1.4.6; fixed in 1.4.21\n- nicegui (PyPI): affected from 1.4.6; fixed in 1.4.21\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-32005/ (Markdown: https://insights.sbomify.com/CVE-2024-32005/index.md)","id":"CVE-2024-32005","markdown":"https://insights.sbomify.com/CVE-2024-32005/index.md","name":"CVE-2024-32005","record":{"aliases":["GHSA-mwc7-64wg-pgvj","PYSEC-2026-1704"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Python UI framework","requires_auth":"none","summary":"An attacker can read arbitrary files on the backend filesystem via a local file inclusion vulnerability in the NiceGUI leaflet component.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":8.2,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:L","version":"3.1"},"cwes":[{"id":"CWE-23","name":"Relative Path Traversal"},{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"NiceGUI is an easy-to-use, Python-based UI framework. A local file inclusion is present in the NiceUI leaflet component when requesting resource files under the `/_nicegui/{__version__}/resources/{key}/{path:path}` route. As a result any file on the backend filesystem which the web server has access to can be read by an attacker with access to the NiceUI leaflet website. This vulnerability has been addressed in version 1.4.21. Users are advised to upgrade. There are no known workarounds for this vulnerability.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Local File Inclusion in NiceGUI leaflet component","id":"CVE-2024-32005","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"path_traversal","year":"2024"},"n_packages":3,"n_references":3,"next":{"headline":"Auth bypass in SINEMA Remote Connect Client","id":"CVE-2024-32006"},"packages":[{"ecosystem":"PyPI","fixed":["1.4.21"],"introduced":["1.4.6"],"last_affected":[],"package":"nicegui","purl":null,"source":"GHSA-mwc7-64wg-pgvj"},{"ecosystem":"PyPI","fixed":["1.4.21"],"introduced":["1.4.6"],"last_affected":[],"package":"nicegui","purl":"pkg:pypi/nicegui","source":"GHSA-mwc7-64wg-pgvj"},{"ecosystem":"PyPI","fixed":["1.4.21"],"introduced":["1.4.6"],"last_affected":[],"package":"nicegui","purl":"pkg:pypi/nicegui","source":"PYSEC-2026-1704"}],"prev":{"headline":"Git vulnerable to Remote Code Execution while cloning special-crafted local repositories","id":"CVE-2024-32004"},"products":["nicegui"],"published":"2024-04-12","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-09-06","vendors":["zauberzeug"]},"summary":"An attacker can read arbitrary files on the backend filesystem via a local file inclusion vulnerability in the NiceGUI leaflet component.","url":"https://insights.sbomify.com/CVE-2024-32005/"}