# CVE-2024-32005: Local File Inclusion in NiceGUI leaflet component

> An attacker can read arbitrary files on the backend filesystem via a local file inclusion vulnerability in the NiceGUI leaflet component.

- **Severity:** High 8.2 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Apr 2024
- **Updated:** 6 Sep 2024
- **Also known as:** GHSA-mwc7-64wg-pgvj, PYSEC-2026-1704

## What is CVE-2024-32005?

CVE-2024-32005 is a high-severity path traversal vulnerability in zauberzeug nicegui, published on 12 Apr 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

NiceGUI is an easy-to-use, Python-based UI framework. A local file inclusion is present in the NiceUI leaflet component when requesting resource files under the `/_nicegui/{__version__}/resources/{key}/{path:path}` route. As a result any file on the backend filesystem which the web server has access to can be read by an attacker with access to the NiceUI leaflet website. This vulnerability has been addressed in version 1.4.21. Users are advised to upgrade. There are no known workarounds for this vulnerability.

Weakness: CWE-23 (Relative Path Traversal), CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2024-32005?

3 open source packages ship an affected version, including nicegui.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nicegui` | PyPI | From 1.4.6 | 1.4.21 |
| `nicegui` | PyPI | From 1.4.6 | 1.4.21 |
| `nicegui` | PyPI | From 1.4.6 | 1.4.21 |

## How do I fix CVE-2024-32005?

Upgrade nicegui to 1.4.21 or later.

## Is CVE-2024-32005 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-32005 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-32005 and fix it if it is affected.

What it is: CVE-2024-32005 is a high-severity path traversal vulnerability in zauberzeug nicegui, published on 12 Apr 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-32005 exists.

Affected packages and fixed versions:
- nicegui (PyPI): affected from 1.4.6; fixed in 1.4.21
- nicegui (PyPI): affected from 1.4.6; fixed in 1.4.21
- nicegui (PyPI): affected from 1.4.6; fixed in 1.4.21

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-32005/ (Markdown: https://insights.sbomify.com/CVE-2024-32005/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-32005
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-32005
- OSV: https://osv.dev/vulnerability/CVE-2024-32005

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-32005/
Summaries are generated and may contain mistakes; the official description above is the record.
