# CVE-2024-32021: Local Git clone may hardlink arbitrary user-readable files into the new repository's "objects/" directory

> Attackers can exploit a race condition during local Git clones to create hardlinks to arbitrary user-readable files, potentially exposing sensitive data.

- **Severity:** Low 3.9 (`CVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:C/C:N/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 14 May 2024
- **Updated:** 4 Nov 2025
- **Also known as:** ALPINE-CVE-2024-32021, AZL-42013, AZL-43042, BELL-CVE-2024-32021, BIT-git-2024-32021, CLEANSTART-2026-DT73617, CLSA-2024-1730919636, CLSA-2024-1731523206, CLSA-2026-1767950442, CLSA-2026-1768223578, CLSA-2026-1768392809, CLSA-2026-1768393530, CLSA-2026-1768570231, CLSA-2026-1768917823, DEBIAN-CVE-2024-32021, GHSA-mvxm-9j2h-qjx7, UBUNTU-CVE-2024-32021

## What is CVE-2024-32021?

CVE-2024-32021 is a low-severity vulnerability in Debian Debian Linux, published on 14 May 2024. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Git is a revision control system. Prior to versions 2.45.1, 2.44.1, 2.43.4, 2.42.2, 2.41.1, 2.40.2, and 2.39.4, when cloning a local source repository that contains symlinks via the filesystem, Git may create hardlinks to arbitrary user-readable files on the same filesystem as the target repository in the `objects/` directory. Cloning a local repository over the filesystem may creating hardlinks to arbitrary user-owned files on the same filesystem in the target Git repository's `objects/` directory. When cloning a repository over the filesystem (without explicitly specifying the `file://` protocol or `--no-local`), the optimizations for local cloning
will be used, which include attempting to hard link the object files instead of copying them. While the code includes checks against symbolic links in the source repository, which were added during the fix for CVE-2022-39253, these checks can still be raced because the hard link operation ultimately follows symlinks. If the object on the filesystem appears as a file during the check, and then a symlink during the operation, this will allow the adversary to bypass the check and create hardlinks in the destination objects directory to arbitrary, user-readable files. The problem has been patched in versions 2.45.1, 2.44.1, 2.43.4, 2.42.2, 2.41.1, 2.40.2, and 2.39.4.

Weakness: CWE-547 (Use of Hard-coded, Security-relevant Constants)

## Which versions are affected by CVE-2024-32021?

1 open source package ship an affected version, including git. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `git` | Bitnami | All versions | 2.39.4, 2.40.2, 2.41.1, 2.42.2, 2.43.4, 2.44.1, 2.45.1 |

Products: Debian Debian Linux, Fedoraproject Fedora, Git-Scm Git.

## How do I fix CVE-2024-32021?

Upgrade git to a fixed version for your release line: 2.39.4, 2.40.2, 2.41.1 or 2.42.2.

## Is CVE-2024-32021 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-32021 exists.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-32021 and fix it if it is affected.

What it is: CVE-2024-32021 is a low-severity vulnerability in Debian Debian Linux, published on 14 May 2024. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-32021 exists.

Affected packages and fixed versions:
- git (Bitnami): affected all versions; fixed in 2.39.4, 2.40.2, 2.41.1, 2.42.2, 2.43.4, 2.44.1, 2.45.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-32021/ (Markdown: https://insights.sbomify.com/CVE-2024-32021/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-32021
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-32021
- OSV: https://osv.dev/vulnerability/CVE-2024-32021

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-32021/
Summaries are generated and may contain mistakes; the official description above is the record.
