CVE-2024-3203 c-blosc2 ndlz8x8.c ndlz8_decompress heap-based overflow

High 7.3 Published Updated

A heap-based buffer overflow in c-blosc2 allows remote attackers to execute arbitrary code or cause denial of service via crafted data.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-3203?

CVE-2024-3203 is a high-severity memory corruption vulnerability in c-blosc2, published on 2 Apr 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

A vulnerability, which was classified as critical, was found in c-blosc2 up to 2.13.2. Affected is the function ndlz8_decompress of the file /src/c-blosc2/plugins/codecs/ndlz/ndlz8x8.c. The manipulation leads to heap-based buffer overflow. It is possible to launch the attack remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 2.14.3 is able to address this issue. It is recommended to upgrade the affected component. VDB-259050 is the identifier assigned to this vulnerability.

Weakness: CWE-122

Which versions are affected by CVE-2024-3203?

It affects 1 product.

Products include Blosc C-Blosc2.

How do I fix CVE-2024-3203?

Upgrade to a fixed version.

Upgrade to the fixed version. Memory-safe languages, compiler hardening and fuzzing prevent most new cases. More about Memory corruption.

Is CVE-2024-3203 being exploited?

There is no known exploitation of CVE-2024-3203 in the wild and no public exploit code.

Sources

Also known as AZL-109490, DEBIAN-CVE-2024-3203, GHSA-pf5m-h35j-7c4j, UBUNTU-CVE-2024-3203, openSUSE-SU-2024:13910-1.

Is CVE-2024-3203 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free