{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-3203 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2024-3203 is a high-severity memory corruption vulnerability in c-blosc2, published on 2 Apr 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-3203 and fix it if it is affected.\n\nWhat it is: CVE-2024-3203 is a high-severity memory corruption vulnerability in c-blosc2, published on 2 Apr 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-3203 in the wild and no public exploit code.\n\nAffected product: c-blosc2. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-3203/ (Markdown: https://insights.sbomify.com/CVE-2024-3203/index.md)","id":"CVE-2024-3203","markdown":"https://insights.sbomify.com/CVE-2024-3203/index.md","name":"CVE-2024-3203","record":{"aliases":["AZL-109490","DEBIAN-CVE-2024-3203","GHSA-pf5m-h35j-7c4j","UBUNTU-CVE-2024-3203","openSUSE-SU-2024:13910-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"C data compression library","requires_auth":"none","summary":"A heap-based buffer overflow in c-blosc2 allows remote attackers to execute arbitrary code or cause denial of service via crafted data.","user_interaction":"not_required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"c-blosc2","vendor":"blosc"}],"cvss":{"score":7.3,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-122","name":"Heap-based Buffer Overflow"}],"description":"A vulnerability, which was classified as critical, was found in c-blosc2 up to 2.13.2. Affected is the function ndlz8_decompress of the file /src/c-blosc2/plugins/codecs/ndlz/ndlz8x8.c. The manipulation leads to heap-based buffer overflow. It is possible to launch the attack remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 2.14.3 is able to address this issue. It is recommended to upgrade the affected component. VDB-259050 is the identifier assigned to this vulnerability.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"c-blosc2 ndlz8x8.c ndlz8_decompress heap-based overflow","id":"CVE-2024-3203","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"memory_corruption","year":"2024"},"n_packages":0,"n_references":5,"next":{"headline":"c-blosc2 ndlz4x4.c ndlz4_decompress heap-based overflow","id":"CVE-2024-3204"},"packages":[],"prev":{"headline":"codelyfe Stupid Simple CMS Login Page excessive authentication","id":"CVE-2024-3202"},"products":["c-blosc2"],"published":"2024-04-02","related":[{"cvss_score":7.8,"headline":"blosc2 heap-based buffer overflow","id":"CVE-2020-29367","kev_date_added":null,"published":"2020-11-27"},{"cvss_score":7.5,"headline":"Null dereference in n/a","id":"CVE-2023-37185","kev_date_added":null,"published":"2023-12-25"},{"cvss_score":7.5,"headline":"Null dereference in n/a","id":"CVE-2023-37186","kev_date_added":null,"published":"2023-12-25"},{"cvss_score":7.5,"headline":"Null dereference in n/a","id":"CVE-2023-37187","kev_date_added":null,"published":"2023-12-25"},{"cvss_score":7.5,"headline":"Null dereference in n/a","id":"CVE-2023-37188","kev_date_added":null,"published":"2023-12-25"},{"cvss_score":7.3,"headline":"c-blosc2 ndlz4x4.c ndlz4_decompress heap-based overflow","id":"CVE-2024-3204","kev_date_added":null,"published":"2024-04-02"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-08-01","vendors":["n/a"]},"summary":"A heap-based buffer overflow in c-blosc2 allows remote attackers to execute arbitrary code or cause denial of service via crafted data.","url":"https://insights.sbomify.com/CVE-2024-3203/"}