CVE-2024-32034 Cross-site scripting (XSS) in the decidim admin activity log
An attacker can execute arbitrary scripts in the admin panel via crafted resource names in activity logs, potentially compromising administrator accounts.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2024-32034?
CVE-2024-32034 is a medium-severity cross-site scripting vulnerability in decidim, published on 16 Sep 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
decidim is a Free Open-Source participatory democracy, citizen participation and open government for cities and organizations. The admin panel is subject to potential Cross-site scripting (XSS) attach in case an admin assigns a valuator to a proposal, or does any other action that generates an admin activity log where one of the resources has an XSS crafted. This issue has been addressed in release version 0.27.7, 0.28.2, and newer. Users are advised to upgrade. Users unable to upgrade may redirect the pages /admin and /admin/logs to other admin pages to prevent this access (i.e. `/admin/organization/edit`).
Weakness: CWE-79
Which versions are affected by CVE-2024-32034?
4 open source packages ship an affected version, including decidim-admin. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
decidim-admin RubyGems | All versions | 0.27.7 |
decidim-admin RubyGems | All versions | 0.27.7 |
decidim-admin RubyGems | From 0.28.0 | 0.28.2 |
decidim-admin RubyGems | From 0.28.0 | 0.28.2 |
Products include Decidim Decidim.
How do I fix CVE-2024-32034?
Upgrade decidim-admin to a fixed version for your release line: 0.27.7 or 0.28.2.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2024-32034 being exploited?
There is no known exploitation of CVE-2024-32034 in the wild and no public exploit code.
Other vulnerabilities in decidim
- CVE-2026-23891 Decidim has a Cross-site scripting (XSS) vulnerability via user name field
- CVE-2023-36465 Decidim has broken access control in templates
- CVE-2025-65017 Decidim's private data exports can lead to data leaks
- CVE-2023-32693 Decidim Cross-site Scripting vulnerability in the external link redirections
- CVE-2023-34089 Decidim Cross-site Scripting vulnerability in the processes filter
Sources
Also known as GHSA-rx9f-5ggv-5rh6.