{"answers":{"affected":"4 open source packages ship an affected version, including decidim-admin. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-32034 in the wild and no public exploit code.","fix":"Upgrade decidim-admin to a fixed version for your release line: 0.27.7 or 0.28.2.","what":"CVE-2024-32034 is a medium-severity cross-site scripting vulnerability in decidim, published on 16 Sep 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2024-32034 and fix it if it is affected.\n\nWhat it is: CVE-2024-32034 is a medium-severity cross-site scripting vulnerability in decidim, published on 16 Sep 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2024-32034 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- decidim-admin (RubyGems): affected all versions; fixed in 0.27.7\n- decidim-admin (RubyGems): affected all versions; fixed in 0.27.7\n- decidim-admin (RubyGems): affected from 0.28.0; fixed in 0.28.2\n- decidim-admin (RubyGems): affected from 0.28.0; fixed in 0.28.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-32034/ (Markdown: https://insights.sbomify.com/CVE-2024-32034/index.md)","id":"CVE-2024-32034","markdown":"https://insights.sbomify.com/CVE-2024-32034/index.md","name":"CVE-2024-32034","record":{"aliases":["GHSA-rx9f-5ggv-5rh6"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Decidim participatory democracy platform","requires_auth":"low_privilege","summary":"An attacker can execute arbitrary scripts in the admin panel via crafted resource names in activity logs, potentially compromising administrator accounts.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"decidim","vendor":"decidim"}],"cvss":{"score":6.8,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"decidim is a Free Open-Source participatory democracy, citizen participation and open government for cities and organizations. The admin panel is subject to potential Cross-site scripting (XSS) attach in case an admin assigns a valuator to a proposal, or does any other action that generates an admin activity log where one of the resources has an XSS crafted. This issue has been addressed in release version 0.27.7, 0.28.2, and newer. Users are advised to upgrade. Users unable to upgrade may redirect the pages /admin and /admin/logs to other admin pages to prevent this access (i.e. `/admin/organization/edit`).","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Cross-site scripting (XSS) in the decidim admin activity log","id":"CVE-2024-32034","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"xss","year":"2024"},"n_packages":4,"n_references":5,"next":{"headline":"Memory Allocation with Excessive Size Value in SixLabors.ImageSharp","id":"CVE-2024-32035"},"packages":[{"ecosystem":"RubyGems","fixed":["0.27.7"],"introduced":["0"],"last_affected":[],"package":"decidim-admin","purl":null,"source":"GHSA-rx9f-5ggv-5rh6"},{"ecosystem":"RubyGems","fixed":["0.27.7"],"introduced":["0"],"last_affected":[],"package":"decidim-admin","purl":"pkg:gem/decidim-admin","source":"GHSA-rx9f-5ggv-5rh6"},{"ecosystem":"RubyGems","fixed":["0.28.2"],"introduced":["0.28.0"],"last_affected":[],"package":"decidim-admin","purl":null,"source":"GHSA-rx9f-5ggv-5rh6"},{"ecosystem":"RubyGems","fixed":["0.28.2"],"introduced":["0.28.0"],"last_affected":[],"package":"decidim-admin","purl":"pkg:gem/decidim-admin","source":"GHSA-rx9f-5ggv-5rh6"}],"prev":{"headline":"Remote code execution via JNDI resolution in JMX metrics collection in Kafka UI","id":"CVE-2024-32030"},"products":["decidim"],"published":"2024-09-16","related":[{"cvss_score":9.3,"headline":"Decidim has a Cross-site scripting (XSS) vulnerability via user name field","id":"CVE-2026-23891","kev_date_added":null,"published":"2026-04-13"},{"cvss_score":9.1,"headline":"Decidim has broken access control in templates","id":"CVE-2023-36465","kev_date_added":null,"published":"2023-10-06"},{"cvss_score":8.2,"headline":"Decidim's private data exports can lead to data leaks","id":"CVE-2025-65017","kev_date_added":null,"published":"2026-02-03"},{"cvss_score":8.1,"headline":"Decidim Cross-site Scripting vulnerability in the external link redirections","id":"CVE-2023-32693","kev_date_added":null,"published":"2023-07-11"},{"cvss_score":8.1,"headline":"Decidim Cross-site Scripting vulnerability in the processes filter","id":"CVE-2023-34089","kev_date_added":null,"published":"2023-07-11"},{"cvss_score":7.7,"headline":"Decidim allows cross-site scripting (XSS) in the online or hybrid meeting embeds","id":"CVE-2024-45594","kev_date_added":null,"published":"2024-11-13"},{"cvss_score":7.5,"headline":"Decidim amendments can be accepted or rejected by anyone","id":"CVE-2026-40869","kev_date_added":null,"published":"2026-04-21"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-09-16","vendors":["decidim"]},"summary":"An attacker can execute arbitrary scripts in the admin panel via crafted resource names in activity logs, potentially compromising administrator accounts.","url":"https://insights.sbomify.com/CVE-2024-32034/"}