# CVE-2024-32034: Cross-site scripting (XSS) in the decidim admin activity log

> An attacker can execute arbitrary scripts in the admin panel via crafted resource names in activity logs, potentially compromising administrator accounts.

- **Severity:** Medium 6.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 16 Sep 2024
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-rx9f-5ggv-5rh6

## What is CVE-2024-32034?

CVE-2024-32034 is a medium-severity cross-site scripting vulnerability in decidim, published on 16 Sep 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

decidim is a Free Open-Source participatory democracy, citizen participation and open government for cities and organizations. The admin panel is subject to potential Cross-site scripting (XSS) attach in case an admin assigns a valuator to a proposal, or does any other action that generates an admin activity log where one of the resources has an XSS crafted. This issue has been addressed in release version 0.27.7, 0.28.2, and newer. Users are advised to upgrade. Users unable to upgrade may redirect the pages /admin and /admin/logs to other admin pages to prevent this access (i.e. `/admin/organization/edit`).

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2024-32034?

4 open source packages ship an affected version, including decidim-admin. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `decidim-admin` | RubyGems | All versions | 0.27.7 |
| `decidim-admin` | RubyGems | All versions | 0.27.7 |
| `decidim-admin` | RubyGems | From 0.28.0 | 0.28.2 |
| `decidim-admin` | RubyGems | From 0.28.0 | 0.28.2 |

Products: Decidim Decidim.

## How do I fix CVE-2024-32034?

Upgrade decidim-admin to a fixed version for your release line: 0.27.7 or 0.28.2.

## Is CVE-2024-32034 being exploited?

There is no known exploitation of CVE-2024-32034 in the wild and no public exploit code.

## Other vulnerabilities in decidim

- [CVE-2026-23891](https://insights.sbomify.com/CVE-2026-23891/): Decidim has a Cross-site scripting (XSS) vulnerability via user name field (critical 9.3)
- [CVE-2023-36465](https://insights.sbomify.com/CVE-2023-36465/): Decidim has broken access control in templates (critical 9.1)
- [CVE-2025-65017](https://insights.sbomify.com/CVE-2025-65017/): Decidim's private data exports can lead to data leaks (high 8.2)
- [CVE-2023-32693](https://insights.sbomify.com/CVE-2023-32693/): Decidim Cross-site Scripting vulnerability in the external link redirections (high 8.1)
- [CVE-2023-34089](https://insights.sbomify.com/CVE-2023-34089/): Decidim Cross-site Scripting vulnerability in the processes filter (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-32034 and fix it if it is affected.

What it is: CVE-2024-32034 is a medium-severity cross-site scripting vulnerability in decidim, published on 16 Sep 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-32034 in the wild and no public exploit code.

Affected packages and fixed versions:
- decidim-admin (RubyGems): affected all versions; fixed in 0.27.7
- decidim-admin (RubyGems): affected all versions; fixed in 0.27.7
- decidim-admin (RubyGems): affected from 0.28.0; fixed in 0.28.2
- decidim-admin (RubyGems): affected from 0.28.0; fixed in 0.28.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-32034/ (Markdown: https://insights.sbomify.com/CVE-2024-32034/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-32034
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-32034
- OSV: https://osv.dev/vulnerability/CVE-2024-32034

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-32034/
Summaries are generated and may contain mistakes; the official description above is the record.
