CVE-2024-32037 GeoNetwork vulnerable to search end-point information disclosure in response headers
Attackers can identify the underlying Elasticsearch software via search response headers, facilitating targeted attacks against the GeoNetwork catalog application.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-32037?
CVE-2024-32037 is a vulnerability in core-geonetwork, published on 11 Feb 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
GeoNetwork is a catalog application to manage spatially referenced resources. In versions prior to 4.2.10 and 4.4.5, the search end-point response headers contain information about Elasticsearch software in use. This information is valuable from a security point of view because it allows software used by the server to be easily identified. GeoNetwork 4.4.5 and 4.2.10 fix this issue. No known workarounds are available.
Weakness: CWE-200
Which versions are affected by CVE-2024-32037?
4 open source packages ship an affected version, including org.geonetwork-opensource:gn-services. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.geonetwork-opensource:gn-services Maven | All versions | 4.2.10 |
org.geonetwork-opensource:gn-services Maven | All versions | 4.2.10 |
org.geonetwork-opensource:gn-services Maven | From 4.4.0 | 4.4.5 |
org.geonetwork-opensource:gn-services Maven | From 4.4.0 | 4.4.5 |
Products include Osgeo Geonetwork.
How do I fix CVE-2024-32037?
Upgrade org.geonetwork-opensource:gn-services to a fixed version for your release line: 4.2.10 or 4.4.5.
Is CVE-2024-32037 being exploited?
There is no known exploitation of CVE-2024-32037 in the wild and no public exploit code.
Other vulnerabilities in core-geonetwork
Sources
Also known as GHSA-52rf-25hq-5m33.