CVE-2024-3204 c-blosc2 ndlz4x4.c ndlz4_decompress heap-based overflow

High 7.3 Published Updated

A heap-based buffer overflow in c-blosc2 allows remote attackers to execute arbitrary code or cause denial of service via crafted data.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-3204?

CVE-2024-3204 is a high-severity memory corruption vulnerability in c-blosc2, published on 2 Apr 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

A vulnerability has been found in c-blosc2 up to 2.13.2 and classified as critical. Affected by this vulnerability is the function ndlz4_decompress of the file /src/c-blosc2/plugins/codecs/ndlz/ndlz4x4.c. The manipulation leads to heap-based buffer overflow. The attack can be launched remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 2.14.3 is able to address this issue. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-259051.

Weakness: CWE-122

Which versions are affected by CVE-2024-3204?

It affects 1 product.

Products include Blosc C-Blosc2.

How do I fix CVE-2024-3204?

Upgrade to a fixed version.

Upgrade to the fixed version. Memory-safe languages, compiler hardening and fuzzing prevent most new cases. More about Memory corruption.

Is CVE-2024-3204 being exploited?

There is no known exploitation of CVE-2024-3204 in the wild and no public exploit code.

Sources

Also known as AZL-109493, DEBIAN-CVE-2024-3204, GHSA-c52r-8hmj-x4qg, UBUNTU-CVE-2024-3204.

Is CVE-2024-3204 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free