CVE-2024-32077 Apache Airflow: XSS vulnerability in Task Instance Log/Log Details

Medium 5.4 Published Updated

An authenticated attacker can inject malicious scripts into task instance logs, potentially leading to code execution or account takeover in Apache Airflow.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2024-32077?

CVE-2024-32077 is a medium-severity cross-site scripting vulnerability in Apache Airflow, published on 14 May 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

Apache Airflow version 2.9.0 has a vulnerability that allows an authenticated attacker to inject malicious data into the task instance logs.  Users are recommended to upgrade to version 2.9.1, which fixes this issue.

Weakness: CWE-79

Which versions are affected by CVE-2024-32077?

4 open source packages ship an affected version, including apache-airflow and airflow. It affects 1 product.

PackageAffectedFixed in
apache-airflow PyPIAll versions to 2.9.0-NANone
apache-airflow PyPIFrom 2.9.02.9.1
apache-airflow PyPIFrom 2.9.02.9.1
airflow BitnamiFrom 2.9.02.9.1

Products include Apache Airflow.

How do I fix CVE-2024-32077?

Upgrade apache-airflow to 2.9.1 or later.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2024-32077 being exploited?

There is no known exploitation of CVE-2024-32077 in the wild and no public exploit code.

All Apache Airflow vulnerabilities

Sources

Also known as BIT-airflow-2024-32077, GHSA-52gm-qmg3-r4qp, PYSEC-2024-264.

Is CVE-2024-32077 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free