# CVE-2024-32077: Apache Airflow: XSS vulnerability in Task Instance Log/Log Details

> An authenticated attacker can inject malicious scripts into task instance logs, potentially leading to code execution or account takeover in Apache Airflow.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 14 May 2024
- **Updated:** 27 Mar 2025
- **Also known as:** BIT-airflow-2024-32077, GHSA-52gm-qmg3-r4qp, PYSEC-2024-264

## What is CVE-2024-32077?

CVE-2024-32077 is a medium-severity cross-site scripting vulnerability in Apache Airflow, published on 14 May 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Apache Airflow version 2.9.0 has a vulnerability that allows an authenticated attacker to inject malicious data into the task instance logs. 
Users are recommended to upgrade to version 2.9.1, which fixes this issue.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2024-32077?

4 open source packages ship an affected version, including apache-airflow and airflow. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache-airflow` | PyPI | All versions to 2.9.0-NA | None |
| `apache-airflow` | PyPI | From 2.9.0 | 2.9.1 |
| `apache-airflow` | PyPI | From 2.9.0 | 2.9.1 |
| `airflow` | Bitnami | From 2.9.0 | 2.9.1 |

Products: Apache Airflow.

## How do I fix CVE-2024-32077?

Upgrade apache-airflow to 2.9.1 or later.

## Is CVE-2024-32077 being exploited?

There is no known exploitation of CVE-2024-32077 in the wild and no public exploit code.

## Other vulnerabilities in Apache Airflow

- [CVE-2020-13927](https://insights.sbomify.com/CVE-2020-13927/): Apache Airflow's Experimental API Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2020-11978](https://insights.sbomify.com/CVE-2020-11978/): Apache Airflow Command Injection (high 8.8, exploited in the wild)
- [CVE-2026-33264](https://insights.sbomify.com/CVE-2026-33264/): Apache Airflow: DAG author RCE on webserver via unrestricted import_string() in BaseSerialization.deserialize() (critical 9.8)
- [CVE-2023-25754](https://insights.sbomify.com/CVE-2023-25754/): Apache Airflow: Privilege escalation using airflow logs (critical 9.8)
- [CVE-2023-22884](https://insights.sbomify.com/CVE-2023-22884/): Apache Airflow, Apache Airflow MySQL Provider: Arbitrary file read via MySQL provider in Apache Airflow (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-32077 and fix it if it is affected.

What it is: CVE-2024-32077 is a medium-severity cross-site scripting vulnerability in Apache Airflow, published on 14 May 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-32077 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache-airflow (PyPI): affected all versions up to 2.9.0-NA; no fix listed
- apache-airflow (PyPI): affected from 2.9.0; fixed in 2.9.1
- apache-airflow (PyPI): affected from 2.9.0; fixed in 2.9.1
- airflow (Bitnami): affected from 2.9.0; fixed in 2.9.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-32077/ (Markdown: https://insights.sbomify.com/CVE-2024-32077/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-32077
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-32077
- OSV: https://osv.dev/vulnerability/CVE-2024-32077

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-32077/
Summaries are generated and may contain mistakes; the official description above is the record.
