CVE-2024-32111 WordPress core < 6.5.5 - Auth. Arbitrary .html File Read (Windows Only) vulnerability
Authenticated attackers can read arbitrary .html files on Windows servers via path traversal in WordPress core.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-32111?
CVE-2024-32111 is a medium-severity path traversal vulnerability in Automattic WordPress, published on 25 Jun 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') vulnerability in Automattic WordPress allows Relative Path Traversal.This issue affects WordPress: from 6.5 through 6.5.4, from 6.4 through 6.4.4, from 6.3 through 6.3.4, from 6.2 through 6.2.5, from 6.1 through 6.1.6, from 6.0 through 6.0.8, from 5.9 through 5.9.9, from 5.8 through 5.8.9, from 5.7 through 5.7.11, from 5.6 through 5.6.13, from 5.5 through 5.5.14, from 5.4 through 5.4.15, from 5.3 through 5.3.17, from 5.2 through 5.2.20, from 5.1 through 5.1.18, from 5.0 through 5.0.21, from 4.9 through 4.9.25, from 4.8 through 4.8.24, from 4.7 through 4.7.28, from 4.6 through 4.6.28, from 4.5 through 4.5.31, from 4.4 through 4.4.32, from 4.3 through 4.3.33, from 4.2 through 4.2.37, from 4.1 through 4.1.40.
Weakness: CWE-22
Which versions are affected by CVE-2024-32111?
2 open source packages ship an affected version, including wordpress and wordpress-multisite.
| Package | Affected | Fixed in |
|---|---|---|
wordpress Bitnami | From 4.1.0 | 4.1.41, 4.2.38, 4.3.34, 4.4.33, 4.5.32, 4.6.29, 4.7.29, 4.8.25, 4.9.26, 5.0.22, 5.1.19, 5.2.21, 5.3.18, 5.4.16, 5.5.15, 5.6.14, 5.7.12, 5.8.10, 5.9.10, 6.0.9, 6.1.7, 6.2.6, 6.3.5, 6.4.5, 6.5.5 |
wordpress-multisite Bitnami | From 4.1.0 | 4.1.41, 4.2.38, 4.3.34, 4.4.33, 4.5.32, 4.6.29, 4.7.29, 4.8.25, 4.9.26, 5.0.22, 5.1.19, 5.2.21, 5.3.18, 5.4.16, 5.5.15, 5.6.14, 5.7.12, 5.8.10, 5.9.10, 6.0.9, 6.1.7, 6.2.6, 6.3.5, 6.4.5, 6.5.5 |
How do I fix CVE-2024-32111?
Upgrade wordpress to a fixed version for your release line: 4.1.41, 4.2.38, 4.3.34 or 4.4.33.
Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.
Is CVE-2024-32111 being exploited?
There is no known exploitation of CVE-2024-32111 in the wild and no public exploit code.
Sources
Also known as BIT-wordpress-2024-32111, BIT-wordpress-multisite-2024-32111, CVE-2022-4947, GHSA-6j7w-22rc-9895, UBUNTU-CVE-2024-32111.