{"answers":{"affected":"2 open source packages ship an affected version, including wordpress and wordpress-multisite.","exploited":"There is no known exploitation of CVE-2024-32111 in the wild and no public exploit code.","fix":"Upgrade wordpress to a fixed version for your release line: 4.1.41, 4.2.38, 4.3.34 or 4.4.33.","what":"CVE-2024-32111 is a medium-severity path traversal vulnerability in Automattic WordPress, published on 25 Jun 2024. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-32111 and fix it if it is affected.\n\nWhat it is: CVE-2024-32111 is a medium-severity path traversal vulnerability in Automattic WordPress, published on 25 Jun 2024. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-32111 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- wordpress (Bitnami): affected from 4.1.0; fixed in 4.1.41, 4.2.38, 4.3.34, 4.4.33, 4.5.32, 4.6.29, 4.7.29, 4.8.25, 4.9.26, 5.0.22, 5.1.19, 5.2.21, 5.3.18, 5.4.16, 5.5.15, 5.6.14, 5.7.12, 5.8.10, 5.9.10, 6.0.9, 6.1.7, 6.2.6, 6.3.5, 6.4.5, 6.5.5\n- wordpress-multisite (Bitnami): affected from 4.1.0; fixed in 4.1.41, 4.2.38, 4.3.34, 4.4.33, 4.5.32, 4.6.29, 4.7.29, 4.8.25, 4.9.26, 5.0.22, 5.1.19, 5.2.21, 5.3.18, 5.4.16, 5.5.15, 5.6.14, 5.7.12, 5.8.10, 5.9.10, 6.0.9, 6.1.7, 6.2.6, 6.3.5, 6.4.5, 6.5.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-32111/ (Markdown: https://insights.sbomify.com/CVE-2024-32111/index.md)","id":"CVE-2024-32111","markdown":"https://insights.sbomify.com/CVE-2024-32111/index.md","name":"CVE-2024-32111","record":{"aliases":["BIT-wordpress-2024-32111","BIT-wordpress-multisite-2024-32111","CVE-2022-4947","GHSA-6j7w-22rc-9895","UBUNTU-CVE-2024-32111"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"WordPress core","requires_auth":"low_privilege","summary":"Authenticated attackers can read arbitrary .html files on Windows servers via path traversal in WordPress core.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"Patchstack","cpe":[],"cvss":{"score":5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') vulnerability in Automattic WordPress allows Relative Path Traversal.This issue affects WordPress: from 6.5 through 6.5.4, from 6.4 through 6.4.4, from 6.3 through 6.3.4, from 6.2 through 6.2.5, from 6.1 through 6.1.6, from 6.0 through 6.0.8, from 5.9 through 5.9.9, from 5.8 through 5.8.9, from 5.7 through 5.7.11, from 5.6 through 5.6.13, from 5.5 through 5.5.14, from 5.4 through 5.4.15, from 5.3 through 5.3.17, from 5.2 through 5.2.20, from 5.1 through 5.1.18, from 5.0 through 5.0.21, from 4.9 through 4.9.25, from 4.8 through 4.8.24, from 4.7 through 4.7.28, from 4.6 through 4.6.28, from 4.5 through 4.5.31, from 4.4 through 4.4.32, from 4.3 through 4.3.33, from 4.2 through 4.2.37, from 4.1 through 4.1.40.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"WordPress core \u003c 6.5.5 - Auth. Arbitrary .html File Read (Windows Only) vulnerability","id":"CVE-2024-32111","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"path_traversal","year":"2024"},"n_packages":2,"n_references":2,"next":{"headline":"WordPress Leadinfo plugin \u003c= 1.0 - Cross Site Request Forgery (CSRF) vulnerability","id":"CVE-2024-32112"},"packages":[{"ecosystem":"Bitnami","fixed":["4.1.41","4.2.38","4.3.34","4.4.33","4.5.32","4.6.29","4.7.29","4.8.25","4.9.26","5.0.22","5.1.19","5.2.21","5.3.18","5.4.16","5.5.15","5.6.14","5.7.12","5.8.10","5.9.10","6.0.9","6.1.7","6.2.6","6.3.5","6.4.5","6.5.5"],"introduced":["4.1.0","4.2.0","4.3.0","4.4.0","4.5.0","4.6.0","4.7.0","4.8.0","4.9.0","5.0.0","5.1.0","5.2.0","5.3.0","5.4.0","5.5.0","5.6.0","5.7.0","5.8.0","5.9.0","6.0.0","6.1.0","6.2.0","6.3.0","6.4.0","6.5.0"],"last_affected":[],"package":"wordpress","purl":"pkg:bitnami/wordpress","source":"BIT-wordpress-2024-32111"},{"ecosystem":"Bitnami","fixed":["4.1.41","4.2.38","4.3.34","4.4.33","4.5.32","4.6.29","4.7.29","4.8.25","4.9.26","5.0.22","5.1.19","5.2.21","5.3.18","5.4.16","5.5.15","5.6.14","5.7.12","5.8.10","5.9.10","6.0.9","6.1.7","6.2.6","6.3.5","6.4.5","6.5.5"],"introduced":["4.1.0","4.2.0","4.3.0","4.4.0","4.5.0","4.6.0","4.7.0","4.8.0","4.9.0","5.0.0","5.1.0","5.2.0","5.3.0","5.4.0","5.5.0","5.6.0","5.7.0","5.8.0","5.9.0","6.0.0","6.1.0","6.2.0","6.3.0","6.4.0","6.5.0"],"last_affected":[],"package":"wordpress-multisite","purl":"pkg:bitnami/wordpress-multisite","source":"BIT-wordpress-multisite-2024-32111"}],"prev":{"headline":"Cross-site request forgery in WpEvently","id":"CVE-2024-32110"},"products":["WordPress"],"published":"2024-06-25","related":[],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-04-28","vendors":["Automattic"]},"summary":"Authenticated attackers can read arbitrary .html files on Windows servers via path traversal in WordPress core.","url":"https://insights.sbomify.com/CVE-2024-32111/"}