CVE-2024-32113 Apache OFBiz Path Traversal
Attackers can exploit a path traversal flaw in Apache OFBiz to achieve remote code execution, requiring an upgrade to the latest version.
- Exploited in the wild
- Since 7 Aug 2024
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- None listed
What is CVE-2024-32113?
CVE-2024-32113 is a critical path traversal vulnerability in Apache Ofbiz, published on 8 May 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') vulnerability in Apache OFBiz.This issue affects Apache OFBiz: before 18.12.13.
Users are recommended to upgrade to version 18.12.13, which fixes the issue.
Weakness: CWE-22
Which versions are affected by CVE-2024-32113?
It affects 1 product.
Products include Apache Ofbiz.
How do I fix CVE-2024-32113?
No fix has been published for CVE-2024-32113 yet. Limit exposure of the affected software until one is available. US federal agencies must fix it by 28 Aug 2024.
Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.
Is CVE-2024-32113 being exploited?
Yes. Attackers have exploited CVE-2024-32113 in the wild since at least 7 Aug 2024.
Public exploit code: 1 Metasploit module, 1 Exploit-DB entry, 1 Nuclei template and 5 proofs of concept on GitHub.
Other vulnerabilities in Apache Ofbiz
- CVE-2024-45195 Apache OFBiz Forced Browsing
- CVE-2024-38856 Apache OFBiz Incorrect Authorization
- CVE-2013-2250 Code injection in n/a
- CVE-2012-3506 Unspecified vulnerability in the Apache Open For Business Project (aka OFBiz) 10.04.x before 10.04.03 has unknown impact and attack vectors.
- CVE-2026-45434 Apache OFBiz: Authentication Bypass via Password-Change Logic Flaw Leading to RCE
Sources
Also known as GHSA-38cv-ch3v-j5cw.