{"answers":{"affected":"3 open source packages ship an affected version, including org.apache.activemq:apache-activemq and activemq. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-32114 exists.","fix":"Upgrade org.apache.activemq:apache-activemq to 6.1.2 or later.","what":"CVE-2024-32114 is a high-severity missing authorization vulnerability in Apache Activemq, published on 2 May 2024. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2024-32114 and fix it if it is affected.\n\nWhat it is: CVE-2024-32114 is a high-severity missing authorization vulnerability in Apache Activemq, published on 2 May 2024. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-32114 exists.\n\nAffected packages and fixed versions:\n- org.apache.activemq:apache-activemq (Maven): affected from 6.0.0; fixed in 6.1.2\n- org.apache.activemq:apache-activemq (Maven): affected from 6.0.0; fixed in 6.1.2\n- activemq (Bitnami): affected from 6.0.0; fixed in 6.1.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-32114/ (Markdown: https://insights.sbomify.com/CVE-2024-32114/index.md)","id":"CVE-2024-32114","markdown":"https://insights.sbomify.com/CVE-2024-32114/index.md","name":"CVE-2024-32114","record":{"aliases":["BIT-activemq-2024-32114","GHSA-gj5m-m88j-v7c3"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["data_read","data_modify"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Apache ActiveMQ","requires_auth":"none","summary":"Unauthenticated attackers can access Jolokia and REST APIs to interact with the broker, produce/consume messages, or delete destinations due to insecure default configuration.","user_interaction":"required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"activemq","vendor":"apache"}],"cvss":{"score":8.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:A/AC:L/PR:N/UI:R/S:C/C:H/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-1188","name":"Initialization of a Resource with an Insecure Default"}],"description":"In Apache ActiveMQ 6.x, the default configuration doesn't secure the API web context (where the Jolokia JMX REST API and the Message REST API are located).\nIt means that anyone can use these layers without any required authentication. Potentially, anyone can interact with the broker (using Jolokia JMX REST API) and/or produce/consume messages or purge/delete destinations (using the Message REST API).\n\nTo mitigate, users can update the default conf/jetty.xml configuration file to add authentication requirement:\n\u003cbean id=\"securityConstraintMapping\" class=\"org.eclipse.jetty.security.ConstraintMapping\"\u003e\n  \u003cproperty name=\"constraint\" ref=\"securityConstraint\" /\u003e\n  \u003cproperty name=\"pathSpec\" value=\"/\" /\u003e\n\u003c/bean\u003e\n\nOr we encourage users to upgrade to Apache ActiveMQ 6.1.2 where the default configuration has been updated with authentication by default.","ecosystems":["Bitnami","Maven"],"exploits":{"exploitdb":0,"first_seen":"2026-04-20","github_poc":1,"max_poc_stars":86,"metasploit":0,"nuclei":1,"refs":[{"date":"2026-04-20T02:38:50Z","kind":"github_poc","ref":"https://github.com/Catherines77/ActiveMQ-EXPtools","stars":86,"title":"Apache ActiveMQ漏洞综合利用工具(CVE-2015-5254，CVE-2016-3088，CVE-2022-41678，CVE-2023-46604，CVE-2024-32114，CVE-2026-34197，CVE-2026-40466， CVE-2026-42588)"},{"date":null,"kind":"nuclei","ref":"http/cves/2024/CVE-2024-32114.yaml","stars":null,"title":"Apache ActiveMQ 6.x \u003c 6.1.2 - Broken Access Control"}],"tier":"weaponised"},"has_fix":true,"headline":"Apache ActiveMQ: Jolokia and REST API were not secured with default configuration","id":"CVE-2024-32114","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"apache:activemq","products":["apache:activemq"],"type":"missing_authorization","year":"2024"},"n_packages":3,"n_references":1,"next":{"headline":"Path traversal in FortiManager","id":"CVE-2024-32115"},"packages":[{"ecosystem":"Bitnami","fixed":["6.1.2"],"introduced":["6.0.0"],"last_affected":[],"package":"activemq","purl":"pkg:bitnami/activemq","source":"BIT-activemq-2024-32114"},{"ecosystem":"Maven","fixed":["6.1.2"],"introduced":["6.0.0"],"last_affected":[],"package":"org.apache.activemq:apache-activemq","purl":null,"source":"GHSA-gj5m-m88j-v7c3"},{"ecosystem":"Maven","fixed":["6.1.2"],"introduced":["6.0.0"],"last_affected":[],"package":"org.apache.activemq:apache-activemq","purl":"pkg:maven/org.apache.activemq/apache-activemq","source":"GHSA-gj5m-m88j-v7c3"}],"prev":{"headline":"Apache OFBiz Path Traversal","id":"CVE-2024-32113"},"products":["Apache ActiveMQ"],"published":"2024-05-02","related":[{"cvss_score":10,"headline":"Apache ActiveMQ Deserialization of Untrusted Data","id":"CVE-2023-46604","kev_date_added":"2023-11-02","published":"2023-10-27"},{"cvss_score":9.8,"headline":"Apache ActiveMQ Improper Input Validation","id":"CVE-2016-3088","kev_date_added":"2022-02-10","published":"2016-06-01"},{"cvss_score":8.8,"headline":"Apache ActiveMQ Improper Input Validation","id":"CVE-2026-34197","kev_date_added":"2026-04-16","published":"2026-04-07"},{"cvss_score":9.8,"headline":"Remote code execution in Apache ActiveMQ","id":"CVE-2020-11998","kev_date_added":null,"published":"2020-09-10"},{"cvss_score":9.8,"headline":"Command Injection in Xstream","id":"CVE-2013-7285","kev_date_added":null,"published":"2019-05-15"},{"cvss_score":9.8,"headline":"Improper Restriction of XML External Entity Reference in Apache ActiveMQ","id":"CVE-2014-3600","kev_date_added":null,"published":"2017-10-27"},{"cvss_score":9.8,"headline":"Improper Input Validation in Apache ActiveMQ","id":"CVE-2015-5254","kev_date_added":null,"published":"2016-01-08"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"MIT","name":"Nuclei templates"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2024-08-02","vendors":["Apache Software Foundation"]},"summary":"Unauthenticated attackers can access Jolokia and REST APIs to interact with the broker, produce/consume messages, or delete destinations due to insecure default configuration.","url":"https://insights.sbomify.com/CVE-2024-32114/"}