# CVE-2024-32114: Apache ActiveMQ: Jolokia and REST API were not secured with default configuration

> Unauthenticated attackers can access Jolokia and REST APIs to interact with the broker, produce/consume messages, or delete destinations due to insecure default configuration.

- **Severity:** High 8.5 (`CVSS:3.1/AV:A/AC:L/PR:N/UI:R/S:C/C:H/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 2 May 2024
- **Updated:** 2 Aug 2024
- **Also known as:** BIT-activemq-2024-32114, GHSA-gj5m-m88j-v7c3

## What is CVE-2024-32114?

CVE-2024-32114 is a high-severity missing authorization vulnerability in Apache Activemq, published on 2 May 2024. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

In Apache ActiveMQ 6.x, the default configuration doesn't secure the API web context (where the Jolokia JMX REST API and the Message REST API are located).
It means that anyone can use these layers without any required authentication. Potentially, anyone can interact with the broker (using Jolokia JMX REST API) and/or produce/consume messages or purge/delete destinations (using the Message REST API).

To mitigate, users can update the default conf/jetty.xml configuration file to add authentication requirement:
<bean id="securityConstraintMapping" class="org.eclipse.jetty.security.ConstraintMapping">
  <property name="constraint" ref="securityConstraint" />
  <property name="pathSpec" value="/" />
</bean>

Or we encourage users to upgrade to Apache ActiveMQ 6.1.2 where the default configuration has been updated with authentication by default.

Weakness: CWE-1188 (Initialization of a Resource with an Insecure Default)

## Which versions are affected by CVE-2024-32114?

3 open source packages ship an affected version, including org.apache.activemq:apache-activemq and activemq. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.activemq:apache-activemq` | Maven | From 6.0.0 | 6.1.2 |
| `org.apache.activemq:apache-activemq` | Maven | From 6.0.0 | 6.1.2 |
| `activemq` | Bitnami | From 6.0.0 | 6.1.2 |

Products: Apache Activemq.

## How do I fix CVE-2024-32114?

Upgrade org.apache.activemq:apache-activemq to 6.1.2 or later.

## Is CVE-2024-32114 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-32114 exists.

Public exploit code:

- Apache ActiveMQ漏洞综合利用工具(CVE-2015-5254，CVE-2016-3088，CVE-2022-41678，CVE-2023-46604，CVE-2024-32114，CVE-2026-34197，CVE-2026-40466， CVE-2026-42588) (github_poc): https://github.com/Catherines77/ActiveMQ-EXPtools
- Apache ActiveMQ 6.x < 6.1.2 - Broken Access Control (nuclei): http/cves/2024/CVE-2024-32114.yaml

## Other vulnerabilities in Apache Activemq

- [CVE-2023-46604](https://insights.sbomify.com/CVE-2023-46604/): Apache ActiveMQ Deserialization of Untrusted Data (critical 10.0, exploited in the wild)
- [CVE-2016-3088](https://insights.sbomify.com/CVE-2016-3088/): Apache ActiveMQ Improper Input Validation (critical 9.8, exploited in the wild)
- [CVE-2026-34197](https://insights.sbomify.com/CVE-2026-34197/): Apache ActiveMQ Improper Input Validation (high 8.8, exploited in the wild)
- [CVE-2020-11998](https://insights.sbomify.com/CVE-2020-11998/): Remote code execution in Apache ActiveMQ (critical 9.8)
- [CVE-2013-7285](https://insights.sbomify.com/CVE-2013-7285/): Command Injection in Xstream (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-32114 and fix it if it is affected.

What it is: CVE-2024-32114 is a high-severity missing authorization vulnerability in Apache Activemq, published on 2 May 2024. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-32114 exists.

Affected packages and fixed versions:
- org.apache.activemq:apache-activemq (Maven): affected from 6.0.0; fixed in 6.1.2
- org.apache.activemq:apache-activemq (Maven): affected from 6.0.0; fixed in 6.1.2
- activemq (Bitnami): affected from 6.0.0; fixed in 6.1.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-32114/ (Markdown: https://insights.sbomify.com/CVE-2024-32114/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-32114
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-32114
- OSV: https://osv.dev/vulnerability/CVE-2024-32114

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-32114/
Summaries are generated and may contain mistakes; the official description above is the record.
