{"answers":{"affected":"3 open source packages ship an affected version, including anki. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-32152 exists.","fix":"Upgrade anki to 24.6 or later.","what":"CVE-2024-32152 is a low-severity vulnerability in Ankitects Anki, published on 22 Jul 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2024-32152 and fix it if it is affected.\n\nWhat it is: CVE-2024-32152 is a low-severity vulnerability in Ankitects Anki, published on 22 Jul 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-32152 exists.\n\nAffected packages and fixed versions:\n- anki (PyPI): affected all versions; fixed in 24.6\n- anki (PyPI): affected all versions; fixed in 24.6\n- anki (PyPI): affected all versions; fixed in 24.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-32152/ (Markdown: https://insights.sbomify.com/CVE-2024-32152/index.md)","id":"CVE-2024-32152","markdown":"https://insights.sbomify.com/CVE-2024-32152/index.md","name":"CVE-2024-32152","record":{"aliases":["DEBIAN-CVE-2024-32152","GHSA-q47p-v5rw-v574","PYSEC-2026-1117","UBUNTU-CVE-2024-32152"],"analysis":{"component_type":"desktop_application","fix_type":"upgrade","impacts":["code_execution","privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"Anki flashcard app","requires_auth":"none","summary":"Attackers can create arbitrary files via malicious flashcards, potentially leading to code execution or privilege escalation in Anki.","user_interaction":"required","vuln_class":"file_upload"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"talos","cpe":[{"product":"anki","vendor":"ankitects"}],"cvss":{"score":3.1,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-184","name":"Incomplete List of Disallowed Inputs"}],"description":"A blocklist bypass vulnerability exists in the LaTeX functionality of Ankitects Anki 24.04. A specially crafted malicious flashcard can lead to an arbitrary file creation at a fixed path. An attacker can share a malicious flashcard to trigger this vulnerability.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Ankitects Anki LaTeX Blocklist Bypass vulnerability","id":"CVE-2024-32152","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"file_upload","year":"2024"},"n_packages":3,"n_references":1,"next":{"headline":"File upload in n/a","id":"CVE-2024-32161"},"packages":[{"ecosystem":"PyPI","fixed":["24.6"],"introduced":["0"],"last_affected":[],"package":"anki","purl":null,"source":"GHSA-q47p-v5rw-v574"},{"ecosystem":"PyPI","fixed":["24.6"],"introduced":["0"],"last_affected":[],"package":"anki","purl":"pkg:pypi/anki","source":"GHSA-q47p-v5rw-v574"},{"ecosystem":"PyPI","fixed":["24.6"],"introduced":["0"],"last_affected":[],"package":"anki","purl":"pkg:pypi/anki","source":"PYSEC-2026-1117"}],"prev":{"headline":"Information disclosure in Multiple MFPs (multifunction printers)","id":"CVE-2024-32151"},"products":["Anki"],"published":"2024-07-22","related":[{"cvss_score":7.4,"headline":"Cross-site scripting in Anki","id":"CVE-2024-32484","kev_date_added":null,"published":"2024-07-22"},{"cvss_score":6.7,"headline":"Code injection in Anki","id":"CVE-2025-62185","kev_date_added":null,"published":"2025-10-07"},{"cvss_score":6.7,"headline":"Command injection in Anki","id":"CVE-2025-62186","kev_date_added":null,"published":"2025-10-07"},{"cvss_score":6.1,"headline":"Security feature bypass in Anki","id":"CVE-2025-43703","kev_date_added":null,"published":"2025-04-16"},{"cvss_score":2.9,"headline":"Path traversal in Anki","id":"CVE-2025-62187","kev_date_added":null,"published":"2025-10-07"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-11-04","vendors":["Ankitects"]},"summary":"Attackers can create arbitrary files via malicious flashcards, potentially leading to code execution or privilege escalation in Anki.","url":"https://insights.sbomify.com/CVE-2024-32152/"}