# CVE-2024-32152: Ankitects Anki LaTeX Blocklist Bypass vulnerability

> Attackers can create arbitrary files via malicious flashcards, potentially leading to code execution or privilege escalation in Anki.

- **Severity:** Low 3.1 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 22 Jul 2024
- **Updated:** 4 Nov 2025
- **Also known as:** DEBIAN-CVE-2024-32152, GHSA-q47p-v5rw-v574, PYSEC-2026-1117, UBUNTU-CVE-2024-32152

## What is CVE-2024-32152?

CVE-2024-32152 is a low-severity vulnerability in Ankitects Anki, published on 22 Jul 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

A blocklist bypass vulnerability exists in the LaTeX functionality of Ankitects Anki 24.04. A specially crafted malicious flashcard can lead to an arbitrary file creation at a fixed path. An attacker can share a malicious flashcard to trigger this vulnerability.

Weakness: CWE-184 (Incomplete List of Disallowed Inputs)

## Which versions are affected by CVE-2024-32152?

3 open source packages ship an affected version, including anki. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `anki` | PyPI | All versions | 24.6 |
| `anki` | PyPI | All versions | 24.6 |
| `anki` | PyPI | All versions | 24.6 |

Products: Ankitects Anki.

## How do I fix CVE-2024-32152?

Upgrade anki to 24.6 or later.

## Is CVE-2024-32152 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-32152 exists.

## Other vulnerabilities in Ankitects Anki

- [CVE-2024-32484](https://insights.sbomify.com/CVE-2024-32484/): Cross-site scripting in Anki (high 7.4)
- [CVE-2025-62185](https://insights.sbomify.com/CVE-2025-62185/): Code injection in Anki (medium 6.7)
- [CVE-2025-62186](https://insights.sbomify.com/CVE-2025-62186/): Command injection in Anki (medium 6.7)
- [CVE-2025-43703](https://insights.sbomify.com/CVE-2025-43703/): Security feature bypass in Anki (medium 6.1)
- [CVE-2025-62187](https://insights.sbomify.com/CVE-2025-62187/): Path traversal in Anki (low 2.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-32152 and fix it if it is affected.

What it is: CVE-2024-32152 is a low-severity vulnerability in Ankitects Anki, published on 22 Jul 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-32152 exists.

Affected packages and fixed versions:
- anki (PyPI): affected all versions; fixed in 24.6
- anki (PyPI): affected all versions; fixed in 24.6
- anki (PyPI): affected all versions; fixed in 24.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-32152/ (Markdown: https://insights.sbomify.com/CVE-2024-32152/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-32152
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-32152
- OSV: https://osv.dev/vulnerability/CVE-2024-32152

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-32152/
Summaries are generated and may contain mistakes; the official description above is the record.
