CVE-2024-3238 WordPress Menu Plugin — Superfly Responsive Menu <= 5.0.29 - Cross-Site Request Forgery to Arbitrary File Deletion

High 8.8 Published Updated

Unauthenticated attackers can delete arbitrary files via CSRF by tricking administrators into clicking a link in the Superfly Responsive Menu plugin.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
None listed

What is CVE-2024-3238?

CVE-2024-3238 is a high-severity vulnerability in looks_awesome WordPress Menu Plugin — Superfly Responsive Menu, published on 2 Aug 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

The WordPress Menu Plugin — Superfly Responsive Menu plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 5.0.29. This is due to missing or incorrect nonce validation on the ajax_handle_delete_icons() function. This makes it possible for unauthenticated attackers to delete arbitrary files via a forged request granted they can trick a site administrator into performing an action such as clicking on a link. Please not the CSRF was patched in 5.0.28, however, adequate directory traversal protection wasn't introduced until 5.0.30.

Weakness: CWE-352

Which versions are affected by CVE-2024-3238?

How do I fix CVE-2024-3238?

No fix has been published for CVE-2024-3238 yet. Limit exposure of the affected software until one is available.

Is CVE-2024-3238 being exploited?

There is no known exploitation of CVE-2024-3238 in the wild and no public exploit code.

Sources

Also known as GHSA-8hj3-fhcj-rg42.

Is CVE-2024-3238 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free