{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2024-3238 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2024-3238 yet. Limit exposure of the affected software until one is available.","what":"CVE-2024-3238 is a high-severity vulnerability in looks_awesome WordPress Menu Plugin — Superfly Responsive Menu, published on 2 Aug 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2024-3238 and fix it if it is affected.\n\nWhat it is: CVE-2024-3238 is a high-severity vulnerability in looks_awesome WordPress Menu Plugin — Superfly Responsive Menu, published on 2 Aug 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2024-3238 in the wild and no public exploit code.\n\nAffected product: looks_awesome WordPress Menu Plugin — Superfly Responsive Menu. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-3238/ (Markdown: https://insights.sbomify.com/CVE-2024-3238/index.md)","id":"CVE-2024-3238","markdown":"https://insights.sbomify.com/CVE-2024-3238/index.md","name":"CVE-2024-3238","record":{"aliases":["GHSA-8hj3-fhcj-rg42"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"WordPress plugin","requires_auth":"none","summary":"Unauthenticated attackers can delete arbitrary files via CSRF by tricking administrators into clicking a link in the Superfly Responsive Menu plugin.","user_interaction":"required","vuln_class":"csrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"Wordfence","cpe":[],"cvss":{"score":8.8,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-352","name":"Cross-Site Request Forgery"}],"description":"The WordPress Menu Plugin — Superfly Responsive Menu plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 5.0.29. This is due to missing or incorrect nonce validation on the ajax_handle_delete_icons() function. This makes it possible for unauthenticated attackers to delete arbitrary files via a forged request granted they can trick a site administrator into performing an action such as clicking on a link. Please not the CSRF was patched in 5.0.28, however, adequate directory traversal protection wasn't introduced until 5.0.30.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":null,"headline":"WordPress Menu Plugin — Superfly Responsive Menu \u003c= 5.0.29 - Cross-Site Request Forgery to Arbitrary File Deletion","id":"CVE-2024-3238","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"csrf","year":"2024"},"n_packages":0,"n_references":2,"next":{"headline":"PostX \u003c 4.0.2 - Contributor+ Stored XSS","id":"CVE-2024-3239"},"packages":[],"prev":{"headline":"ConvertPlug \u003c= 3.5.25 - Missing Authorization to Authenticated (Subscriber+) Limited Arbitrary Options Update","id":"CVE-2024-3237"},"products":["WordPress Menu Plugin — Superfly Responsive Menu"],"published":"2024-08-02","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-04-08","vendors":["looks_awesome"]},"summary":"Unauthenticated attackers can delete arbitrary files via CSRF by tricking administrators into clicking a link in the Superfly Responsive Menu plugin.","url":"https://insights.sbomify.com/CVE-2024-3238/"}