# CVE-2024-32461: LibreNMS vulnerable to time-based SQL injection that leads to database extraction

> An attacker with read privileges can exploit SQL injection to extract database contents, including administrator credentials, from LibreNMS.

- **Severity:** High 7.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Apr 2024
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-cwx6-cx7x-4q34

## What is CVE-2024-32461?

CVE-2024-32461 is a high-severity SQL injection vulnerability in Librenms Librenms, published on 22 Apr 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

LibreNMS is an open-source, PHP/MySQL/SNMP-based network monitoring system. A SQL injection vulnerability in POST /search/search=packages in LibreNMS prior to version 24.4.0 allows a user with global read privileges to execute SQL commands via the package parameter. With this vulnerability, an attacker can exploit a SQL injection time based vulnerability to extract all data from the database, such as administrator credentials. Version 24.4.0 contains a patch for the vulnerability.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2024-32461?

2 open source packages ship an affected version, including librenms/librenms. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `librenms/librenms` | Packagist | All versions | 24.4.0 |
| `librenms/librenms` | Packagist | All versions | 24.4.0 |

Products: Librenms Librenms.

## How do I fix CVE-2024-32461?

Upgrade librenms/librenms to 24.4.0 or later.

## Is CVE-2024-32461 being exploited?

There is no known exploitation of CVE-2024-32461 in the wild and no public exploit code.

## Other vulnerabilities in Librenms Librenms

- [CVE-2023-4982](https://insights.sbomify.com/CVE-2023-4982/): Cross-site Scripting (XSS) - Stored in librenms/librenms (critical 9.8)
- [CVE-2022-29712](https://insights.sbomify.com/CVE-2022-29712/): Command injection in librenms (critical 9.8)
- [CVE-2021-44278](https://insights.sbomify.com/CVE-2021-44278/): Path traversal in librenms/librenms (critical 9.8)
- [CVE-2019-10665](https://insights.sbomify.com/CVE-2019-10665/): LibreNMS Information Disclosure (critical 9.8)
- [CVE-2018-20434](https://insights.sbomify.com/CVE-2018-20434/): LibreNMS arbitrary OS commands execution (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-32461 and fix it if it is affected.

What it is: CVE-2024-32461 is a high-severity SQL injection vulnerability in Librenms Librenms, published on 22 Apr 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-32461 in the wild and no public exploit code.

Affected packages and fixed versions:
- librenms/librenms (Packagist): affected all versions; fixed in 24.4.0
- librenms/librenms (Packagist): affected all versions; fixed in 24.4.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-32461/ (Markdown: https://insights.sbomify.com/CVE-2024-32461/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-32461
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-32461
- OSV: https://osv.dev/vulnerability/CVE-2024-32461

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-32461/
Summaries are generated and may contain mistakes; the official description above is the record.
