{"answers":{"affected":"3 open source packages ship an affected version, including sentry. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-32474 in the wild and no public exploit code.","fix":"Upgrade sentry to 24.4.1 or later.","what":"CVE-2024-32474 is a high-severity vulnerability in getsentry sentry, published on 18 Apr 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2024-32474 and fix it if it is affected.\n\nWhat it is: CVE-2024-32474 is a high-severity vulnerability in getsentry sentry, published on 18 Apr 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2024-32474 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- sentry (PyPI): affected from 24.3.0; fixed in 24.4.1\n- sentry (PyPI): affected from 24.3.0; fixed in 24.4.1\n- sentry (PyPI): affected from 24.3.0; fixed in 24.4.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-32474/ (Markdown: https://insights.sbomify.com/CVE-2024-32474/index.md)","id":"CVE-2024-32474","markdown":"https://insights.sbomify.com/CVE-2024-32474/index.md","name":"CVE-2024-32474","record":{"aliases":["GHSA-6cjm-4pxw-7xp9","PYSEC-2026-1911"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Sentry error tracking","requires_auth":"low_privilege","summary":"Sentry leaks superuser passwords in cleartext logs, allowing attackers with log access to gain administrative control.","user_interaction":"required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"sentry","vendor":"sentry"}],"cvss":{"score":7.3,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-312","name":"Cleartext Storage of Sensitive Information"},{"id":"CWE-117","name":"Improper Output Neutralization for Logs"}],"description":"Sentry is an error tracking and performance monitoring platform. Prior to 24.4.1, when authenticating as a superuser to Sentry with a username and password, the password is leaked as cleartext in logs under the _event_: `auth-index.validate_superuser`. An attacker with access to the log data could use these leaked credentials to login to the Sentry system as superuser. Self-hosted users on affected versions should upgrade to 24.4.1 or later. Users can configure the logging level to exclude logs of the `INFO` level and only generate logs for levels at `WARNING` or more.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Sentry's superuser cleartext password leaked in logs","id":"CVE-2024-32474","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"information_disclosure","year":"2024"},"n_packages":3,"n_references":4,"next":{"headline":"Envoy RELEASE_ASSERT using auto_sni with :authority header \u003e 255 bytes","id":"CVE-2024-32475"},"packages":[{"ecosystem":"PyPI","fixed":["24.4.1"],"introduced":["24.3.0"],"last_affected":[],"package":"sentry","purl":null,"source":"GHSA-6cjm-4pxw-7xp9"},{"ecosystem":"PyPI","fixed":["24.4.1"],"introduced":["24.3.0"],"last_affected":[],"package":"sentry","purl":"pkg:pypi/sentry","source":"GHSA-6cjm-4pxw-7xp9"},{"ecosystem":"PyPI","fixed":["24.4.1"],"introduced":["24.3.0"],"last_affected":[],"package":"sentry","purl":"pkg:pypi/sentry","source":"PYSEC-2026-1911"}],"prev":{"headline":"Moby IPv6 enabled on IPv4-only network interfaces","id":"CVE-2024-32473"},"products":["sentry"],"published":"2024-04-18","related":[{"cvss_score":9.1,"headline":"Sentry: Improper authentication on SAML SSO process allows user identity linking","id":"CVE-2026-42354","kev_date_added":null,"published":"2026-05-08"},{"cvss_score":9.1,"headline":"Sentry: Improper Authentication on SAML SSO process allows user identity linking","id":"CVE-2026-27197","kev_date_added":null,"published":"2026-02-21"},{"cvss_score":8.7,"headline":"Sentry 8.2.0 Remote Code Execution via Pickle Deserialization","id":"CVE-2021-47935","kev_date_added":null,"published":"2026-05-10"},{"cvss_score":8.1,"headline":"Sentry vulnerable to privilege escalation via ApiTokensEndpoint","id":"CVE-2023-39349","kev_date_added":null,"published":"2023-08-07"},{"cvss_score":7.7,"headline":"Sentry vulnerable to improper authorization on debug and artifact file downloads","id":"CVE-2023-36826","kev_date_added":null,"published":"2023-07-25"},{"cvss_score":7.5,"headline":"Sentry: Inefficient Regular Expression Complexity in sentry","id":"CVE-2026-52794","kev_date_added":null,"published":"2026-06-24"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-08-02","vendors":["getsentry"]},"summary":"Sentry leaks superuser passwords in cleartext logs, allowing attackers with log access to gain administrative control.","url":"https://insights.sbomify.com/CVE-2024-32474/"}